When I embed an excel files into powerpoint, I'm having two issues.

  • On some of the spreadsheets, empty columns are displayed on the right hand side of the powerpoint slide
  • On other spreadsheets that are too large to fit, I can't adjust the bounds of what I'd like to be displayed on the slide. So, I couldn't choose a larger area to display of the excel spreadsheet and just size it down. It arbitrarily chooses where to cut off the excel spreadsheet on the slide.

Is there any way to adjust which part of the excel file is embedded?

9 Answers 9

  1. Double click on the spreadsheet to "activate" it.
  2. Move your cursor to the black mark on the right side of the sheet, halfway between the top and bottom.
  3. When the cursor changes to a two-way horizontal arrow, click and hold.
  4. Then drag the right edge to show as many columns as you want. There is a maximum amount of column space available- once you pass a certain limit it will not show any more columns.

Example of resizing the displayed columns.
Embedded Spreadsheet

  • 2
    I don't get how to do it. I don't see any "black mark on the right side"
    – simpatico
    Commented Apr 25, 2011 at 12:58
  • 1
    I do not remember, but you have to be either inside or outside the Excel editing mode. Then there will be square marks (or similar anchors) with which you can change the size of the Excel add-in in terms of the number of columns and rows (as opposed to resizing the Excel add-in as a whole, which is possible in the other editing mode; as I said, I can't remember, which is which).
    – robert
    Commented Mar 11, 2012 at 12:07
  • @simpatico, on the powerpoint slide, select the object, right click and choose Worksheet Object --> Edit
    – eric
    Commented Apr 5, 2017 at 22:16

Same problem here, I have a workaround for some simpler cases:

  • go into Edit on the embedded Excel
  • Select the region you want to show
  • copy it (Ctrl+C)
  • go into powerpoint again
  • use paste special and paste as an excel object
  • delete the old object

Ugly but works in simple cases (no multiple sheets and calculations).


The question was specifically around a 'live link' (meaning the Excel file exists externally to the Word doc, and controlling the view is a complex problem not solved by any of these answers).

Answer: Using the Word Field Code parameters of LINK you can specify a named range as a Viewing Area.

Specific steps:

  1. Excel: Select the cells (contiguous range) to be seen in Word, 'Insert Named Range' or Alt-I,N,D, Type name for region (no spaces for simplicity, e.g. "WordView"), Confirm named range exists (this step can happen before/after)

  2. Word: Insert | Object, 'From File', (choose XLS file), check 'Link to File' (to ensure it's kept 'fresh'), OK

  3. Word: Select the newly inserted XLS object/image. Press Shift-F9 to reveal codes. You should see something like:

    { LINK Excel.Sheet.12 "C:\\...\\YourFile.xls" \a \f 0 \p }

  4. Word: Change the field code by adding your named range (e.g. "WordView") as the third parameter. E.g.:

    { LINK Excel.Sheet.12 "C:\\...\\YourFile.xls" WordView \a \f 0 \p }

  5. Word: With the field code under cursor, hit Shift-F9 again to hide. Select embedded XLS object/image and press F9 to update (or right click etc). ... You should see the view properly.

To change the 'viewing window', simply re-define or update the named range from within Excel, save, then select and F9 the object/image in Word and you should be good to go.

Cheers - Ronald

  • 1
    I'm not an Office user, but I assume the above is right. (Nice first post!) Still then: does this also apply to PowerPoint instead of Word? (As asked for in the question.)
    – Arjan
    Commented May 27, 2014 at 19:53
  • Couldn't get this to work. The spreadsheet didn't change length, it added extra cells still. Perhaps you could update your answer with more information?
    – Eoin
    Commented Sep 18, 2019 at 18:25

I have the same problem, but in Word instead of Powerpoint. I haven't exactly found a true solution, but I do have a work around that may work if you need to readjust for an undersized excel chart:

  1. Copy the range you would like from Excel.
  2. Paste>Paste Special and select to paste link as excel.
  3. Left click to highlight the excel object, right click on it and select crop.
  4. Crop the extra rows/columns out of the object.
  5. Exit cropping function, then pull on the corners or sides of the object to resize it to fit your page/margins.

Like I said, not a true fix, but through I'd post it here in case of anyone else finds this useful.

  • Found an issue with this method. Cropping seems to create issues when you convert it to PDF, where parts of the sheet gets chopped off. I am unable to test if it has any issues with normal printing, since the work computers always crashes if I try to print directly off any microsoft office program.
    – Chloe L
    Commented Jul 1, 2014 at 21:12
  • This worked well for me
    – Eoin
    Commented Sep 18, 2019 at 18:25

Sometimes when you insert a spreadsheet as an embedded file using the Insert > Object method it goes a bit weird and refuses to adjust the size properly.

The best way I have found is to highlight the area you are copying in Excel, right click on ppt slide and page embedded object - the icon looks like a little white box in the middle of the paste special options. This will paste it with the boundaries you originally highlighted. Be careful if you need to edit though as it is pretty unstable and may reset the boundaries again.


In the 'activated' state (when clicked on), the Excel object has a border around it. Halfway on each border (top, left, right, bottom) is a small black box. If you acquire the box you can drag it to resize the visible area of the spreadsheet. Then click outside the box to return to Powerpoint.


You must double click the embedded object to edit it in Word. Cells that reflect what is currently displayed will be selected. Select the cells that you want to be displayed. Select elsewhere in the main document to stop editing in the embedded object.


This applies for MS word (2007), so I can only assume the same goes for powerpoint.

  1. double click the embedded worksheet to "select" it
  2. click the arrow in the very upper left corner, next to "A" and "1"
  3. now when you adjust the size of the embedded object, it will instead change how many rows/cols. instead of scaling the size.

I know this is old but I think I was having the same issue in Office 2013. When I copied a named range in excel and used paste special as "linked excel worksheet object" in ppt, I always ended up with extra columns to the right in my ppt slide. It was bugging me to death so hopefully this may help a few people.

For me, the issue was the page view in excel. If I switched to Normal view in excel, the cells show fine in ppt.

If the excel worksheet is in the "page layout" view (which is what i was using when copying the cells), it always led to extra columns shown when pasting or updating link in ppt.

If I switched to normal view, it pasted fine in ppt with the correct column numbers. If you switch back to a different page layout in excel and then update link in ppt, the extra columns will come back.

Hope this helps some people.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .