I'm struggling with rvm. This isn't the first time I've installed rvm, and it isn't the first time I've had problems with it, but this problem is proving to be a right pain; and all of the articles that appear related are either completely out of date, or don't solve it.

I've installed rvm, but when I try to install any version of Ruby I receive an error.

Here's the command I'm using:

$ rvm package install readline  
$ rvm install ree -C --with-readline-dir=$HOME/.rvm/usr  

ree-1.8.7-2010.02 - #fetching (ruby-enterprise-1.8.7-2010.02)  
ree-1.8.7-2010.02 - #extracting ruby-enterprise-1.8.7-2010.02 to /Users/Richard/.rvm/src/ree-1.8.7-2010.02  
ree-1.8.7-2010.02 - #installing  
Error running './installer -a /Users/Richard/.rvm/rubies/ree-1.8.7-2010.02  --dont-install-useful-gems ', please check /Users/Richard/.rvm/log/ree-1.8.7-2010.02/install*.log  
There has been an error while trying to run the ree installer. Halting the installation.  

and in the log file:

ossl_x509revoked.c:64: warning: passing argument 2 of ‘ASN1_dup’ from incompatible pointer type  
readline.c: In function ‘username_completion_proc_call’:  
readline.c:734: error: ‘username_completion_function’ undeclared (first use in this function)  
readline.c:734: error: (Each undeclared identifier is reported only once  
readline.c:734: error: for each function it appears in.)  
make[1]: *** [readline.o] Error 1  
make: *** [all] Error 1

Given that I'm explicitly telling rvm to use another install of readline, does anyone know where I'm going wrong?


  • The developer of RVM (Wayne Sequin) is extremely helpful and available quite often via IRC; I'd bet he could diagnose this issue pretty quickly (see IRC info on top-right of rvm.beginrescueend.com) – yalestar Sep 15 '10 at 3:02

Updated to the latest version of rvm

rvm get stable

and then ran rvm reload

rvm reload

which seems to have solved this issue.

| improve this answer | |
  • 1
    update: rvm (checked in v1.11.5) now uses: rvm get stable instead of rvm update --head – Dave Everitt Apr 1 '12 at 16:57

I struggled with the readline problem as well. Turns on the problem was not having the right pre-requisites. I solved it by making sure everything was installed:

sudo apt-get install build-essential bison openssl \
     libreadline6 libreadline6-dev curl git-core \
     lib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-0 \
     libsqlite3-dev sqlite3 libxml2-dev libxslt-dev \
     autoconf libc6-dev ncurses-dev

I've written up a complete tutorial to getting RVM running perfectly on Ubuntu 11.04:


| improve this answer | |
  • I also linked to your blog in my answer before. Hope that's okay for you! – slhck Jun 20 '11 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.