The slot-loading optical drive in my Dell Studio Hybrid has been acting up. Sometimes it works fine, sometimes it churns and makes some unpleasant sounds. Now I can't even get it to eject the disc that's in there.

Many drives have an "emergency eject" pinhole, but I don't see one here. How can I get the disc out?

11 Answers 11


I had this happen to me, only worse when I learnt the hard way not to put miniCDs into slot-load CD drives!

I tried the below things, and eventually managed to get it out. Admittedly some of these have potential to get you into a worse mess than you already are :P

  • Inserting a piece of cardboard with double-sided stickytape to try and stick to and pull out CD.
  • Pushing the CD further in then trying to eject
  • Inserting another (expendable) CD on top of the existing and ejecting both
  • As above but with double sided table on the top CD

Ultimately if none of these work you last option is to remove the drive and try and get it out once it's outside the laptop.

  • 2
    The cardboard and tape trick has worked for me in the past. Some drives will also do a force eject if you hold down the eject button for a while ('x' seconds) - provided the mechanism is not jammed. – Linker3000 Sep 15 '10 at 10:13

Try rebooting, and also try ejecting from inside the computer - right click on the disc in My Computer and click 'Eject'...if that doesn't work, I hope some else has some suggestions...

  • Tried that, and it didn't work. Thanks for trying, though. – Jay Bazuzi Sep 15 '10 at 4:08
  • @Jay Bazuzi: hope you find an answer, I'd be interested too, i have a slot drive also... – studiohack Sep 15 '10 at 4:15

I ran into the same issue. I took the Studio Hybrid apart and removed the DVD drive (screw on outer case, screw for cover, screw for HDD/DVD Assembly, 4 screws to remove DVD drive). there were 4 small screws on the DVD drive that, once removed, allowed the DVD to be pulled straight out.


I had this happen on my Dell Studio with slot-type drive. Pressing the Eject key next to the function keys didn't work and the drive did not show up in My Computer. Eventually it ejected itself when I switched off, switched back on and repeatedly clicked on the above mentioned eject key whilst the computer was booting.


Dell Studio slot drives are not very forgiving! I have found that slightly warped disks may hang up when trying to exit through the slot. Drive makes clicking sounds as it attempts to eject the disk. The plastic bezel around the slot may distend as disk pushes against it from the inside.

This may account for why a disk will suddenly eject after numerous attempts ... the warp happens to properly align with the slot and finally makes it through.

Check for disk warp by placing the disk on a flat surface and pressing down on the edge (in several different locations). If the disk wobbles slightly, it is warped. Insert at your own risk!


I had the same problem, dvd jammed in my Dell Stuido 15, no disk drive showing in Explorer, and a really annoying noise coming from the laptop! Using a sharp knife I was able to prize the edge of the DVD out just enough to get a grip on it. I was not worried about damaging the DVD, so I was able to force it a little and get it out. Before I moved it, I could see the very edge of the dvd in the drive and this is why I used the knife to yank it out! I've not tried to use the drive itself since!

  • I replaced my DVD drive with a new slot-loader, but it never worked as well as new. In the end I bought an external USB DVD drive and used that instead. – Jay Bazuzi Dec 16 '12 at 4:34

There's a piece of metal that goes up when a CD is inserted to prevent it from popping out, a piece of cardboard and tape won't get past it. Some chubby kid did a YouTube, but I can't find the 12MM G-Spot for the eject switch with the paperclip and his camera was too shaky to see where he was trying to get to. There's no pin hole either!

My scenario is that my hard drive crashed and I'm trying to recover, there's no GUI interface to Right-Click, the keyboard doesn't respond to the Finesse key for ejecting, there is no pin hole, the CD is stuck, so I can't put in a boot-able CD to recover the drive.

Dell Studio 1558 | How to Eject a CD Using Testing Utility: Boot up the machine, and at the Dell Logo, Press the 'P' key and 'F12' at the same time. This will give you power-up options. Arrow down to Diagnostics and Press Enter.

Wait for about a 10 minute test to finish. You will be prompted to interact with the video color test, just Press 'Y' to confirm you are looking at colors. When prompted with 'No problems have been found...' Press 'N' to not continue with the memory test. 'Booting Diagnostic Utility Partition' will appear. Press any key on the keyboard to continue. When prompted to choose an option, arrow to 'Test System' and Press the Spacebar.

The 'Main Menu - Service Tag ' will appear. Arrow to 'Custom Test' and Press Spacebar to select the option. The 'Customize' interface will appear. Double-Click on the 'Keyboard' test, and when prompted with 'This test checks the keyboard...' Press OK to continue. Using the keys on the keyboard, starting with 'Esc', Press on the keyboard each highlighted key, until you finally get to the Finesse Eject button. Your disk will automatically eject! Press ESC twice to exit the test, and then Click on the 'X' to close the testing interfaces that appear. Ultimately, your system will reboot.


I tried doing the keyboard diagnostic test above mentioned and it didn't work for me.

What did work was the CD/DVD test in the custom test section of the diagnostic partition software:

  • Select custom test, then CD/DVD test;
  • After getting to the part of the test that tells you to eject the CD, click "OK" to continue, just click "OK", it will do it 3 times.
  • Then it will say "IT'S GOING TO TEST THE EJECT FEATURE OF THE DRIVE" that's when it will eject out.

Thanks to the guy/gal above for leading me to this fix. Yes it is a crappy design of a laptop.


OK I had problem that disc was stuck and my Dell Studio Hybrid would not even boot up.

I pushed in another DVD about 75% a couple of times and managed to 'pull' out enough of the DVD that was stuck to get that out.

As soon as I did I got back in (admitted via system restore which allowed me to take it back to an earlier point)

Finally this is a last resort this may make it worse so only attempt understanding there a possibly of knackering your DVD drive.


Check to see if there is a little icon that lights up when you turn on the computer. It is located at the lower right hand corner of the screen near where the CD/DVD slot is on the lower right hand side of the All-IN-One Dell Studio one 1909. When it lights up, gently push or tap on it to eject the DVD/CD. I got this solution From Dell Support. It is a touch screen gadget!


I have a dell studio laptop with slot load dvd drive. A dvd got stuck inside the drive, i tried to insert another dvd but it didn't even enter a millimetre. I noticed that there was a clamp like thing preventing the dvd from ejecting, exactly in the center of the slot load. With another dvd i tried to lift the clamp along with pressing eject button pressed simultaneously, suddenly the stuck dvd ejected out. Hope this may help someone.

protected by JakeGould Oct 5 '15 at 7:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.