I have problems with burned CD-RW Audio CDs in K3B. I don't know exactly what's wrong. When I burn mp3s as an Audio CD with K3B, the burning process seems to be ok. But when I want to play this burned CD in my PC's CD ROM, the first seconds are snatchy and it seems that it doesn't begin to play at the 1st song but anywhere else. When I want to play this CD in my car radio, the CD doesn't work at all. My car radio cannot read any songs.

Earlier as I didn't use RW CDs but CD R, I didn't have any problems. Maybe the RWs CDs are the reason? I also tried to burn to a different CD RW - same effect. I also tried to burn at different speeds. Once 10x, once "auto" - same effect.

That's the output of the burning process. Maybe it could help:


HL-DT-ST DVDRAM GH22NS50 TN02 (/dev/sr1, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Layer Jump] [%7] HL-DT-ST DVDROM DH16NS30 1.00 (/dev/sr0, CD-ROM, DVD-ROM) [DVD-ROM, CD-ROM] [None] [%7]


K3b Version: 1.91.0 KDE Version: 4.4.2 (KDE 4.4.2) QT Version: 4.6.2 Kernel: 2.6.32-24-generic

Used versions

cdrecord: 1.1.10


/usr/bin/wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits. scsidev: '/dev/sr1' devname: '/dev/sr1' scsibus: -2 target: -2 lun: -2 Linux sg driver version: 3.5.27 Wodim version: 1.1.10 SCSI buffer size: 64512 Beginning DMA speed test. Set CDR_NODMATEST environment variable if device communication breaks or freezes immediately after that. Text len: 900 TOC Type: 0 = CD-DA Driveropts: 'burnfree' Device type : Removable CD-ROM Version : 5 Response Format: 2 Capabilities : Vendor_info : 'HL-DT-ST' Identification : 'DVDRAM GH22NS50 ' Revision : 'TN02' Device seems to be: Generic mmc2 DVD-R/DVD-RW. Current: 0x000A (CD-RW) Profile: 0x0012 (DVD-RAM) Profile: 0x0011 (DVD-R sequential recording) Profile: 0x0015 (DVD-R/DL sequential recording) Profile: 0x0016 (DVD-R/DL layer jump recording) Profile: 0x0014 (DVD-RW sequential recording) Profile: 0x0013 (DVD-RW restricted overwrite) Profile: 0x001A (DVD+RW) Profile: 0x001B (DVD+R) Profile: 0x002B (DVD+R/DL) Profile: 0x0010 (DVD-ROM) Profile: 0x0009 (CD-R) Profile: 0x000A (CD-RW) (current) Profile: 0x0008 (CD-ROM) Profile: 0x0002 (Removable disk) Using generic SCSI-3/mmc CD-R/CD-RW driver (mmc_cdr). Driver flags : MMC-3 SWABAUDIO BURNFREE Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R Drive buf size : 1053696 = 1029 KB Drive DMA Speed: 15928 kB/s 90x CD 11x DVD FIFO size : 12582912 = 12288 KB Speed set to 1764 KB/s pregap1: -1 Track 01: audio 60 MB (05:57.08) no preemp swab copy Track 02: audio 81 MB (08:06.30) no preemp swab copy Track 03: audio 56 MB (05:33.74) no preemp swab copy ... [has been shortened by me due to character restrictions of Superuser] ... Track 09: 34 of 34 MB written (fifo 100%) [buf 97%] 10.2x. Track 09: Total bytes read/written: 36016176/36016176 (15313 sectors). Writing time: 279.496s Average write speed 10.1x. Min drive buffer fill was 93% Fixating... Fixating time: 10.362s /usr/bin/wodim: fifo had 7275 puts and 7275 gets. /usr/bin/wodim: fifo was 0 times empty and 7063 times full, min fill was 98%.

cdrecord command:

/usr/bin/wodim -v gracetime=2 dev=/dev/sr1 speed=10 -sao driveropts=burnfree textfile=/tmp/qt_temp.MJ2603 -useinfo -audio /tmp/kde-markus/k3b_audio_0_01.inf /tmp/kde-markus/k3b_audio_0_02.inf /tmp/kde-markus/k3b_audio_0_03.inf /tmp/kde-markus/k3b_audio_0_04.inf /tmp/kde-markus/k3b_audio_0_05.inf /tmp/kde-markus/k3b_audio_0_06.inf /tmp/kde-markus/k3b_audio_0_07.inf /tmp/kde-markus/k3b_audio_0_08.inf /tmp/kde-markus/k3b_audio_0_09.inf

Any ideas what's the matter?

[UPDATE] I tried it with Brasero, same effect. But Brasero gives me a warning which describes that CD RW Audio CDs will not work with older CD players. Maybe this explains it. But that doesn't explain why my CD Rom (half a year old) has minor problems too (snatchy at the beginning due to playing difficulties).

  • "Maybe the RWs CDs are the reason?" Yes, that can be. CD-RWs are not 100% compatible to plain CD (have different laser reflection properties) and some audio players simply can't read them. Brasero warnings is justified. Though I expected that by now all the H/W would be capable of doing it... Try plain CD-R with low speed. – Dummy00001 Sep 16 '10 at 12:19

If I am correct you are writing the disc with a dataspeed of 90x. Most of the older CD-Players can´t handle that speed. Try burning it with 16x. I know it takes more time but 8x or 16x should be a speed your player definitely can handle. If not, try it with even lower writing speed.

edit.: I just found a mistake in my answer. You´re writing with an average speed of 10.1x But maybe you could try to slow it down to 8x or less. I´ve got the same problem with older devices. Some of them can only 1x or 2x.

  • Unfortunately I get the following messages: Medium or burner does not support writing at 2x speed. Switching burn speed up to 10x. (I already tried it with 4x). I already burned with this burner on a 800MB CD and it worked in my car. So either something must be wrong with K3B or with these CD RWs. – Bevor Sep 15 '10 at 19:39
  • Maybe it is a problem with the ReWritable part here. I don´t know how K3b is working with these things. Have you tried to burn on these CD-RWs with another burning software or on another os? Maybe it is a manufacturing fault on the discs and has nothing at all to do with your computer ;-) – Diskilla Sep 15 '10 at 20:44
  • I will buy CD R CDs and will try it with them. I'll let you know what happens then. – Bevor Sep 16 '10 at 6:41

Burning to CD R (with 4x speed) seems to work. It even works in my car radio. Obviously burning audio data to CD RW is no good idea. A colleage of mine told me the same. So problem is solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.