When I try to run the install program I get a popup message that says the installer program is not a valid executable.

Background: I want a GPS with maps on my laptop running Ubuntu 10.4LTS. Unfortunately I can't find a decent native Linux GPS solution with 50 state US street level coverage. I have VirtualBox VMs available for WinXP and Win7 (among others). The VMs work fine with MicroSoft Streets and Trips (2010) and MapNGo 5 (a very! old Delorme product), but while both these products support GPS, they don't support the Earthmate LT-40 USB GPS I already have. I've got pretty much every Delorme Street Atlas they've released in the last decade and none of them will install in a VM.

Any help would be much appreciated.

Clarification: I've installed the Delorme products from these CDs before and the disks are fine - as long as installation is done on a "physical" machine.

Added: I've tried install from an iso as well as the real CD. No difference in result (setup.exe is not a valid executable)

The WinXP is SP-2 (held back on purpose at this point - I'll snapshot and fork a later SP to test). The Win2K is SP-6a. Win7(32) VM is whatever updates came out last week.

The USB setup is working at least to the point where the GPS device is active in the device list (has an x in the box). At this point its not relevant because the program that needs to read it can't even be installed.

Added 9-19: Added wine as harrymc suggested. Initial result was no change. Here's wines error message.

The file '/media/Disk1/setup.exe' is not marked as executable.  If this was downloaded or copied form an untrusted source, it may be dangerous to run.  For more details, read about the executable bit.

At first I thought the execute bit was the problem, but looking at several other windows CDs I see that the execute bit is not set on their exe files (which install to VM without error). Still it was worth a shot so I copied the StreetAtlas 9 DVD to my hard disk, changed the on-disk exe files to have the execute bit set and tried to install again. This time the install via wine got me through the installation process. When I start the program it bombs immediately, so we haven't made much real progress so far. I very much prefer the VM solution to wine, so I'm going back to that for now.

To recap the VM situation, using an updated XP with SP3 and all recommended hotfixes: StreetAtlas 2009 USA fails with "not marked as executable".

StreetAtlas 2007 USA fails with "not marked as executable".

StreetAtlas 9 (copyright 2001) fails with "not marked as executable".

SteeetAtlas (copyright 1991) fails with "not marked as executable"

Delorme Topo 4 (copyright 2002) fails with "not marked as executable".

Just about ready to give up. So I switched from XP VM to Win7 VM and tried StreetAtlas 2009 again. This time it installs. Earthmate USB GPS works. WTH?

I feel like the monkey who just wrote a line of Shakespear. I'm smiling because it worked, but I have no clue why.

I'm awarding the bounty to harrymc because wine did give some useful insight into the problem and a +1 to goyiux as thanks for helping.


The article How to Use Street Atlas USA With Linux claims that Street Atlas can be directly installed in Linux without a virtual machine, by using Wine:

Wine lets you run Windows software on other operating systems. With Wine, you can install and run these applications just like you would in Windows.

Not all products function in Wine, but this article seems to indicate that Street Atlas does.

  • @harrymc: That article looks pretty interesting. I'm not a current wine user but that could change... – hotei Sep 19 '10 at 17:06
  • @harrymc: Wine didn't work but it gave much better insight into what is failing than VirtualBox did. – hotei Sep 20 '10 at 1:50
  • Thanks for the bounty. As wine is a community project, you might also consider notifying the developers of the problem. The legal difficulty may be in making available for them a copy of Street Atlas (maybe without most of the maps?). – harrymc Sep 20 '10 at 8:49
  • @harrymc: I'm not comfortable declaring it a wine bug at this point. I'm so new to wine that it could be just my error in configuring something. At this point I'm suspecting that Delorme has made some strange programming choices since their MapNGo products (1990s vintage) all install without problems in multiple VMs. – hotei Sep 20 '10 at 15:30
  • I personally like Wine, which is an enormous achievement. When you said it bombed immediately, what exactly happened and was there an error message by Wine? – harrymc Sep 20 '10 at 16:07

Have you made sure your Windows Installer component is up to date? The latest version as of this posting is Windows Installer 4.5 and it is available for Windows XP SP2 and later.

Beyond that, you might want to experiment with the Program Compatibility Mode. Every version of Windows since WinXP has it available in one form or another.

Have you tried using an ISO created from the installer media versus just associating the physical drive with the VM?

  • Have already tried install with ISO and with the original CD, no difference. Will look into your other suggestions. – hotei Sep 19 '10 at 2:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.