My sounds skips on Ubuntu 10.04 LTS. When I listen to a song, the track will do something weird every now and then. Sometimes it skips a few seconds, sometimes it goes back a few seconds, sometimes it holds.

I'm currently using Exaile, but the same thing happens in all players.

I've tried changing the audio engine from Pulse, to ALSA, or OSS. Doesn't work.

The same computer dual boots on Windows and it works fine in windows with every player. I can play the same media in both OS.

I installed Ubuntu very recently and didn't installed much programs yet.

The only real thing I tried without success was to change the kernel to a "real time" kernel using the command : sudo aptitude install linux-rt.

  • Is your media reliable?
    – Xavierjazz
    Sep 17, 2010 at 15:02
  • @Xavierjazz : Yes. I'm playing the same media from Windows and Linux (and it works in Windows). The question is still justified :) Sep 17, 2010 at 15:05

4 Answers 4


Not likely but have to ask - what does your CPU and memory utilization look like when the skips happen? (System/Administration/System Monitor tab)

If I remember correctly a "real-time OS" only guarantees that an interrupt request will be responded to within a minimum time, not that it will be completed in a minimum time. The completion depends on CPU and RAM and IO resources being available. While most mp3 players have tiny resource footprints it's not impossible to have problems if you're on an older machine. I've induced similar symptoms when running Windows under a VM with very limited resources.

More likely - the symptoms could be caused by the decompression of the sound track failing. I'd be tempted to remove and re-install whatever decoder you're using. Ubuntu 10.4 is capable of reasonably good sound on most systems so don't give up without a fight.

Added: Based on the DROP in CPU use I'd guess either the IO system is unable to fill the decoder input buffer or the decoder is bailing out unexpectedly. Does the problem happen with all CODECs? ie, can you play a .wav file ok but not a .mp3?

The HD on RAID0 (striping) makes me wonder if that could be relevant. Maybe the RAID0 is grabbing the bus a little longer than it should be. Does the problem happen at regular intervals? What is the interval (on average) if not regular. Can you play OEM CDs? Can you play mp3 from CD? Can you make a RAMDISK and play from there? If any of these work without skipping it will shed some light on whether the codec is the problem.

I'm assuming you use the Update Manager to get regular updates. If you haven't done this for a while then do it now. If it grabs any new stuff be sure to verify you still have a problem before proceeding.

How to reinstall decoder(s) - I'd hold off till "last resort" to do this... but if you're still reading then here's how:

It depends on the type of file your playing. This example is for mp3... you'll have to find the decoders in use. Run Pkg Manager then search for mp3. On left hand side click STATUS and pick "Installed". In the list of matched items - on left side the decoders in use will have a solid green box and something about mp3 and decode in the title. For example on my system one file is libmad0, the "MPEG audio decoder library". Record the names you find so you can add them back later. Right click and "mark for removal". Repeat until you're satisfied you've got the main items where the problem MIGHT be. Then go to main icon bar and click apply. Wait for it to finish. If it asks to remove orphaned dependencies try to refuse this (since you're going to add it back shortly) I tend to be paranoid so I'd restart before the next step. Next step is to take your list, search for them same way and add them back. ie mark for installation and then apply.

Even if this works the decoder reinstall leaves open the question of why it broke in the first place... If it doesn't work then ...?

  • 1- CPU utilization drops drastically when the sound skips. Ram is not affected. 2- The machine is brand new. HDD are on raid 0. 3- How do you re-install the decoders ? I didn't install any. On previous installations of Ubuntu (9.04) I didn't install any decoders either... the default ones worked perfectly. Sep 17, 2010 at 17:16
  • Thanks a lot for your help, Hotei. You led me to the answer. Sep 17, 2010 at 18:23

After doing some more research, I found this : Realtek ALC889A - Playback problem, stuttering audio & video . It states that this is a known bug in Ubuntu 10.04 and the description perfectly fits my problem to the last detail. I also check the system log and found a hundred of lines that looked like this :

Sep 17 10:46:32 computername pulseaudio[2296]: ratelimit.c: 990 events suppressed.

So Ubuntu 10.04 bug.


I had exactly the same problem (audio skips and stutters at random, CPU usage low) with Ubuntu 14.04. Upgrading Alsa/DKMS following this procedure solved my issues: https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

  1. make sure dkms is installed: sudo apt-get install dkms
  2. load .deb for your system from https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+packages
  3. install: sudo dpkg -i <deb file>
  4. reboot

I had this problem on Ubuntu 16.04 -- audio was stuttering/skipping regardless of whether I was listening through a browser or media player like Rhythm Box.

I checked /var/log/syslog and had thousands of lines like this:

774771 May 27 12:14:09 xxx-dev kernel: [643229.204121] ath: phy0: DMA failed to stop in 10 ms AR_CR=0xffffffff AR_DIAG_SW=0xffffffff DMADBG_7=0xffffffff
774772 May 27 12:14:09 xxx-dev kernel: [643229.312551] ath: phy0: Chip reset failed
774773 May 27 12:14:09 xxx-dev kernel: [643229.312552] ath: phy0: Unable to reset channel, reset status -22

...some problem with network-manager was causing an infinite loop condition [related].

I already had a wired connection. So I disabled my wireless adapter using the steps listed here and the problem disappeared.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .