5

Normally, when you double-click a cell, you enter in-cell editing mode, right? This works most of the time, but occasionally on random cells, a double-click instead moves the focus to a different cell in the sheet, as if I had simply single-clicked that other cell. If I then double-click the original cell again, it works as expected: I can edit the contents of that cell and everything is normal.

This happens on random cells, regardless what their contents are, and of course they're not hyperlinked or anything like that. It happens on several versions of Excel (XP, 2000, 2003, for certain; can't remember earlier versions). It happens on any computer (at home, at work, at previous workplace...).

This is not a major problem I need to have solved, but why in the world is Excel behaving like that?! I'd just like to understand it.

6

If you double click on (or really near) the border of the cell, the selected cell jumps to the first empty cell to the left in the same row (if it was a side border) or up in the same column (if it was a top/bottom border).

It seems to be more reliable if your cursor is closer to a corner rather than in the middle of a border.

| improve this answer | |
  • +1 - Reproduced in 2007. Solution - click carefully in the middle of the cell, or use F2! – JNK Sep 17 '10 at 19:32
  • Wow, I never noticed a connection between where in the cell I was clicking and the jump direction; it just seemed so random. I also didn't notice that the random target cell was always blank. Wow. Been using Excel since version 0.95 on the Mac in 1986 and still learn new tricks. Amazing! – Torben Gundtofte-Bruun Sep 17 '10 at 20:09
  • Haha, this happened to me as well, and I eventually realized that it would happen if you double click the border - really frustrating. +1 to the answer though. – Kevdog777 May 21 '13 at 8:52
  • Is there any method to disable this behaviour? – István Zachar Jul 28 '15 at 12:21
1

A) One solution, if the original cell is still visible after the focus has jumped to another cell, is to single click the border of the original cell that was double-clicked to bring the focus back to the original cell.

B) Yes, as shown below, it's possible to disable the behavior. However, the downside is that you lose the fill handle and cell drag-and-drop features.

(from: https://www.extendoffice.com/documents/excel/4304-excel-double-click-jumps-to-bottom.html) Disable Double-Click On Cell Border to Jump to Bottom [Top/Side]: To disable double-click on cell border feature, you can go to the Excel Options to configure an option as shown below:

  1. Click File > Options to go to the Excel Options dialog box.

  2. In the Excel Options dialog box, click Advanced option from the left pane, and then uncheck the Enable fill handle and cell drag-and-drop option under the Editing options...

  3. Then click OK to close this dialog box, and now, double-click on cell border feature is disabled at once.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.