19

I am using Ubuntu terminal and want to type this:

sudo -H -u gitosis gitosis-init < ~/.ssh/id_rsa.pub

However I am not able to find tilde (~) on my Norwegian keyboard.

Can anyone tell me how to type it?

1
  • 6
    The name of the symbol is "tilde" in case that helps you find references to it. Sep 18, 2010 at 7:47

5 Answers 5

28

F6 gave me ~ on my key board.

4
  • 5
    F6 is actually outputting something like ^[[17~ (escape-leftbracket-1-7-~). Sep 18, 2010 at 8:07
  • F5 worked on my HP pavilion dv6700, not F6
    – user122023
    Mar 8, 2012 at 15:42
  • I don't know why, but after <kbd>F6</kbd> the <kbd>~</kbd> symbol on keyboard back to work again.
    – ton
    Feb 15, 2016 at 14:09
  • Also on the german keyboard. 😊 Nov 6, 2017 at 19:01
10

AltGr+¨ (umlaut, just below backspace), then (assuming the deadkey variant of the layout) Space.

1
  • And similarly option + ¨ followed by a space on a mac...
    – wogsland
    Jun 28, 2021 at 8:53
9

Hold down together:

  1. Ctrl + Shift + u - Underlined u should appear.
  2. Release keys
  3. Enter 7E (Unicode for ~)
  4. Press Space

For the full list of Unicode codes please refer to the following link:

https://unicode-table.com/en/#control-character

It may look too much, but it's the global solution for all languages and keyboard layouts ,)

8

~ refers to your home directory, so you can always type $HOME instead of ~ ... if you can find $ on your keyboard, that is!

2

Type the combination like Alt gr + (top right char, for me Ü, for you ^) and after typing hit "space".

Briefly: Type the combination and after hit space.

Not the answer you're looking for? Browse other questions tagged or ask your own question.