My gtalk runs behind a proxy at office. To connect, I have to set the following:

Proxy: IMProxy or

Port 8085

Proxy requires authentication: False

I tried but was not able to configure Pidgin with my office proxy.

What are the settings required to make pidgin connect to Google via a proxy?


Here is the screenshot of my gtalk Network connections settings page which works perfectly:

enter image description here



enter image description here


enter image description here

  • are you asking any hacking techniques ? – joe Aug 6 '09 at 15:47
  • No hacking whatsoever! – darthvader Aug 10 '09 at 5:43
  • What protocols are you trying to use with pidgin? IRC, ICQ, etc? – innaM Aug 10 '09 at 10:30
  • jabber(XMPP) for using gtalk – darthvader Aug 10 '09 at 11:04
  • all of what you have above should work. Have you tried everything above w/ the built in Google Talk protocol? – hyperslug Aug 10 '09 at 14:29

The basics are from Google Answer to Configuring Pidgin for Google Talk.
They seem fine.

Beyond that,

  1. Change your Connect server to talk.google.com
    You have been told in other answers to do this,
    but your question image does not reflect that correction
    • Check connectivity through proxy with
      telnet talk.google.com 8085
      This should get a Connected to line and a Escape character is line usually.
      The TCP connect will happen and then get closed since TELNET will not talk gtalk.
      This will confirm the proxy worked to get you through to Google talk server.
    • Do these two tries separately to see if one of them works,
    • Keep the "Force old SSL" and "Allow plain text Auth" both unchecked
    • Keep them both checked -- to see if that works

Update from comment,
When you try telnet talk.google.com 8080,
TELNET connecting and getting closed is a good sign,
like I said, that is expected, TELNET cannot talk with the gtalk server.
It can only do the initial 3-way TCP handshake

  • Telnet: Hello, this is me (SYN);
  • talk.google: Hi there, good to see you (SYN-ACK),
  • Telnet: Oh, you are around, lets talk (ACK)
  • then, TELNET does not know the language to go further :-)
    • but, Pidgin does, and can continue from there...

If you find 8085 does not connect with TELNET and 8080 does,
then, 8080 is very likely the correct proxy port.
(8080 is more commonly used for proxies too).
Have you verified 8085 is declared as the proxy port in your network?

It would be very surprising to find talk.google.com
connect arbitrarily through port 8080 for any other reason,
while, 8085 shows a timeout.

On your updated question with gtalk configuration.
Something is not correct here.

  1. How can your gtalk work for destination port 8085 when you cannot even TELNET to that port?
    • And, Why can you TELNET to 8080 (successful connection, though, it closes after that)
      but then, Pidgin cannot even connect?

You should probably check with netstat, TCPView or maybe wireshark
to see what happens to your connection attempts here.

| improve this answer | |
  • telnet talk.google.com 8085 doesn't work i.e ,"Connecting To talk.google.com...Could not open connection to the host, on port 8 085" but it works with 8080. It is getting connected and closed. – darthvader Aug 11 '09 at 5:17
  • If talk.google.com responds to a connect attempt at 8080 for you, change your Pidgin configuration to that port. – nik Aug 11 '09 at 6:06
  • When you get this working, please tell us your "Force old SSL" and "Allow plain text Auth" configuration settings -- for the record. – nik Aug 11 '09 at 6:14

Choose Proxy Type as HTTP, prover server -> enter the proxy server IP address, port, 8085 (as mentioned above)

| improve this answer | |
  • It is not working. – darthvader Aug 10 '09 at 5:41
  • Does your office have a firewall that's blocking ports? – Sathyajith Bhat Aug 11 '09 at 17:49

Try XMPP as your protocol type.

Try this:

enter image description here

| improve this answer | |
  • Giving SSL connection failed error. Do I need to enter username/password. I tried entering and leaving it blank. Not working either ways. btw, do I have to set the proxy details in Preferences? I tried putting that also :'( – darthvader Aug 10 '09 at 7:39
  • Username Password should be blank here as your proxy doesn't require authentication. Try it without "Force old (port 5223)". BTW, I'm assuming your settings on the Basic page are correct. – hyperslug Aug 10 '09 at 8:03
  • Actually, scratch that. The Connect port should be 443, not 423. Leave Force old port 5223 checked. – hyperslug Aug 10 '09 at 8:12
  • tried all above steps. doesn't work.. "( – darthvader Aug 10 '09 at 9:53

Require SSL/TLS checked

Force old (port 5223) SSL unchecked

Connect port: 5222 (not 5223)

Connect server: talk.google.com

And use HTTP proxy settings or can try Environmental settings.

| improve this answer | |
  • Could not establish a connection with the server: HTTP proxy connection error 407 – darthvader Aug 10 '09 at 11:02
  • I could connect using proxy easily with Gtalk. Is it a problem with Pidgin? – darthvader Aug 10 '09 at 11:02

From what I observed, I have the same problem from my workplace too. There is also a proxy without login/password. Google Talk works, but it won't connect from Pigdin.

In my opinion, it's a matter of port. Google Talk doesn't use the same ports as the XMPP (I might say something silly, correct me if I'm wrong). From tcpview, I could see only ports like 1420, or else, being used.

Fact is, many proxies are configured to refuse tunneling on other ports than a defined list (80, 443, etc). Obviously the GTalk program manages to find a port to connect, but I think the direct connection from Pigdin is somehow refused.

In this case, I don't think he will be able to use it at work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.