30

How can I allow incoming scp connections on my Mac (OS X 10.6.4) from other machines on the same network?

Every time I’m trying to scp something on the machine I get a Connection refused error.

Later edit:

The command used is this:

scp path/to/local.file user@remote.machine:

And the reply is this:

ssh: connect to remothe.machine port 22: Connection refused
lost connection
  • can you post the format of the statement you are using to make this connection? – MaQleod Sep 20 '10 at 8:08
  • @MaQleod: see my edit – Alex Sep 20 '10 at 8:16
  • It sounds as if you need to enable SSH/SCP. – MaQleod Sep 20 '10 at 8:30
42

System Preferences pane → Sharing applet → check the Remote Login checkbox. This will enable SSH, and in turn, SCP.

| improve this answer | |
5

In the settings there is the option to activate SSH. I think it’s under SharingRemote Login.

| improve this answer | |
2

You might have to open a port. My router's address is 192.168.0.1, it's default name is admin and password is, I think, password. Yours might be the same. Check the bottom of your router. Default port is 22.

| improve this answer | |
  • While a closed port on a firewall will cause connection issues, it will cause a time out and not a refused connection. A refused connection is a specific error caused by the TCP handshake being shutdown due to no listening service. In other words, an RST is sent in response to the client's SYN. – MaQleod Nov 21 '16 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.