So I am still trying to troubleshoot this issue for my sister. Running memtest threw up a multitude of errors for the RAM so I went through the company (OCZ) and they agreed to replace it. Finally got the replacement RAM and installed. No joy. Same problems of random crashes (no longer pixelated should point out). Ran Windows Memory Diagnostic this time and once again there are errors with the RAM. I have had faulty RAM before but never have I had a replacement stick not work. This led me to ponder if perhaps something more was going on.

Does anyone elseknow what could possible be wrong? Faulty ram bays (I have tried the RAM in both)? Faulty memory controller (not sure where this is these days but would assume it is on chip now?)? Should my next step be to replace the RAM with a totally different brand and hope?

Really scratching my head on this one and my sister is getting increasingly agitated about the lack of The Sims she is playing at the moment.

EDIT: I should mention it is a Gigabyte GA-P55-USL3 Rev 2 flash with latest BIOS


Usually, I will try each stick of RAM I have in each slot and record the errors and look for a pattern. Generally I find that either one of the RAM dimms or one of the RAM slots is bad. If you run into a situation where you get errors no matter what combinations you try, you are likely looking at a different issue. At this point you need to consider that something on the board is causing your problems. One step to rule out the RAM completely is try it in another machine and re-test. If you see no errors, you probably need a new board (rarely any options for repairing most boards for these types of issues).

| improve this answer | |
  • thanks for the guidance on pattern testing. Will get to it at teh weekend when I get a chance. Is it likely that faulty slots on the motherboard could cause permenant damage to the dimms? – Tim Alexander Sep 21 '10 at 10:07
  • I haven't seen proof of this, and I don't think it could happen, but I'm not 100% sure. – MaQleod Sep 22 '10 at 15:15
  • 1
    turns out the replacement ram was just faulty. bought new ram and tried that. everything worked fine. thanks for the help – Tim Alexander Sep 28 '10 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.