3

I am connecting via RDP to a Windows 7 Professional machine. I use that machine for its data/programs, but at times I also need to (within the RDP connection) connect to a VPN (configured via L2TP/IPSec), not on my client.

The problem is the VPN seems to take over all traffic, so I then lose my RDP connection.

What sort of network configuration (I'm thinking virtual adapters of some sort or the routing table) could I use to get around this?

3 Answers 3

8

I guess this might be fixed by simply disabling the option "Use default gateway on remote network" of the Windows VPN client. In XP that was hidden in the properties of your VPN network, tabsheet "Networking", "Internet Protocol (TCP/IP)", clicking "Properties", and finally clicking "Advanced".

That also means that most other traffic is no longer routed through the VPN. This includes browsing of websites, fetching email through POP or IMAP, and so on.

(However, it is enabled by default for a reason: it makes it a bit harder for malware to keep or reestablish connections once VPN is started, if the VPN administrator has blocked their network for such threats. Also, a company's policy might not allow you to disable it.)

1
  • I found F5 VPN Client's IPV4 properties is configured as you mentioned by default however the connection dropped and I can't connect to F5 VPN within remote desktop, is there any solution? Jul 6, 2020 at 18:31
4

This was rather easy, just had to find the "Use default gateway for remote connection" option and uncheck it. This option was previously more prominent in Windows XP, but is just a little harder to navigate to in Windows 7.

It is located by accesing the properties of the VPN connection and navigating to Networking -> TCP/IP v4 -> Advanced and unchecking "Use default..."

As noted this has security implications and I lost some of the functionality of the VPN (shares). I would really like someone to show how to simply have the RDP connection itself persist via the current network connection, and continue using the VPN on the rest of the time. Bonus if the VPN connection is terminated if the RDP connection terminates?

2
  • 1
    Okay! See my notes about security though!
    – Arjan
    Sep 20, 2010 at 17:57
  • 1
    Noted, anyway to allow an exception only for RDP traffic? Sep 20, 2010 at 19:52
0

This happened to me too. I don't have a "Use default gateway on remote network" checkbox to check. There is a solid workaround: use an alternate method to remote into the machine like GoToMyPC. It uses a different method of connecting, and in my case I was able to connect with it and then initiate the VPN connection without trouble.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.