10

I have this notebook that I use both at work and at home. I often watch a movie at home with my headset plugged in and the volume high enough to be able to hear it well. At work however I listen to my iphone, so I have nothing plugged into the laptop.

Every single morning at work I start working until an error occurs or any other event that causes sound, and I find out my speakers are still on high volume, annoying the crap out of me and my colleagues.

My iPhone switches to the last used volume whenever I plug in or out my headphones. Is there a way for my notebook to do this as well? (I use windows 7)

7

Open the volume mixer (click the speaker icon in the system tray and choose "mixer"), you will probably find the left-most column (Device) will say "Speakers". Click the down-arrow next to this icon - this allows you to choose other devices, such as headphones, and you can then adjust them seperately.

If headphones isn't given as an option, or there's no down-arrow, you may need to right-click the speaker to access further option to unhide the headphones. Alternatively make sure you try this with the headphones connected.

Alternatively you can adjust these using the Sound options in Control Panel, again make sure you unhide disconnected / not active / I-forget-the-term-it-uses devices if you don't see headphones listed at first.

If the headphones option is missing (especially when they are connected) from the mixer and in the Control Panel sound options, then I'm afriad you computer cannot tell the difference between when you are using your speakers or headphones - meaning there is unlikely to be a software solution.

  • Wow, thanks. I never knew those options were there. My system does give the option to change headphones volume vs. speaker volume, but it doesn't seem to switch between the two when I plug them in or out. I think the one it recognizes though is the USB headset I sometimes use for skype, not the 3.5mm ones I use now. I can set it to default to headphones though, which disables the speakers when it's plugged out. Unless you have any tips on how to automatically switch I'll stick to defaulting to the headset :) Thanks! – Stephan Muller Sep 21 '10 at 13:36
  • Hmm, I seem to be wrong on that one. I can select the headset to set its properties but I cannot select it as the device I'm currently using (or as the default audio device for that matter). I think that proves that the system is talking about the USB headset, not this one. Apparently it doesnt work for a regular 3.5mm headset. – Stephan Muller Sep 21 '10 at 13:41
  • @Litso - That's unfortunate. Will it let you just mute or disable the main speaker volume? Not ideal, as it effectively returns you to the original problem but at least you wouldn't get sudden loud blasts. If you want proof RE your USB headset - plug it in, play some music through it, and mess with the volume control. – DMA57361 Sep 21 '10 at 13:48
  • Yeah, I don't have that on me. I fiddled about some more and my current headset just isn't recognized. I'm afraid there's no solution for this problem, I'll have to get used to turning down the volume either after watching something or when starting up in the morning :P – Stephan Muller Sep 21 '10 at 14:12
  • @Litso - Maybe instead you could use something that mutes the volume as you boot up or shutdown? Suggestions in this question may help. – DMA57361 Sep 21 '10 at 14:23
14

Fun fact for everyone with a Realtec sound device (almost everyone):

Uninstalling your vendor driver and reverting back to the Windows default driver enables headphones / speaker differentiation.

(Tested on Win8.1 and 7)

  • 2
    Might be late but also works on Windows 10 Version 1511 Build 10586.164 after removing Realtek HD Audio Manager. Getting rid of the annoying "You've plugged in an audio device" is also an additional plus. – NeVMiku Mar 31 '16 at 1:03
  • How can I do that? – Colonel Panic May 19 '17 at 19:14
  • Also work on Win10. It's the most useless driver I have seen – krrr Aug 27 '17 at 10:53
7

Realtek Devices:

Try to open "Realtek HD Audio Manager" in Control Panel. At top right of the opened window click on "Device advanced settings" and finally on this menu choose "multi streaming mode".

  • Exactly! this is the answer! – wakeup Nov 9 '15 at 20:01
  • This worked for me, although it doesn't adjust the playing audio instantly, resulting in having to reload a page / video etc. – Christopher Markieta Dec 7 '15 at 7:20
  • 1
    ah, thought this would work, but I don't see "Device advanced settings" in Windows 10, Lenovo Yoga – Quang Aug 28 '17 at 22:41
  • I don't see "Multi streaming mode" after clicking on "Device advanced settings," but I do see "Make front and rear output devices playback two different audio streams simultaneously" and choosing it worked. – martias Jan 8 '18 at 21:23
  • Such a weirdly worded option for what I needed. Thanks. – Arturo Torres Sánchez Mar 11 '18 at 4:00
4

If you have SmartAudio(it came with my toshiba laptop) then this is what you do. You click on the Audio Director tab at the bottom, and then select multi-streaming. Then, if you click on the volume icon in the taskbar, you will have headphones and speakers as two separate devices, each able to have different audio levels.

3

Sometimes you should check the driver; if your sound card driver is older than Microsoft Windows 7's release (such as 2010 or earlier) and if you don't use anything like SPDIF of your on-board card, you better use the default driver of Win 7, because it will auto-adjust the volume when you plug in your headphones. Some old drivers can't do that.

0

Windows 10 works hard to make sure that you have the latest drivers, so reverting to the default Windows driver may take some work.
For me, that meant uninstalling the Realtek driver, then uninstalling another (older) Realtek driver that Windows chose to use instead. This reverted to the default Windows driver, BUT Windows immediately and automatically downloaded and installed the newest Realtek driver again.
Then I rolled back the driver to revert to the default Windows driver, and viola!

I wanted to comment on AndreLung's answer above (but I can't, because I'm not special), which solved the issue for me.

0

Uninstalling your vendor driver and installing the Windows default driver enables headphones / speaker sound level differentiation. With realtek high definition audio on Windows 7

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.