Every time I need to access another user's inbox in Outlook 2010, I need to go to File | Open | Other User's Folder. Obviously, this is very time consuming.

If possible, I need a quicker way to access it, without adding the mailbox to the "open these additional mailboxes" list (user doesn't have full access to mailbox). Is there a quicker way?

  • If it's a .pst file, it will appear as a seperate Mailbox. Well, if you had another mailbox to your tree, it will also appear as another seperate mailbox. – r0ca Sep 21 '10 at 14:03
  • @r0ca It's not a .pst file, it is another user's inbox on the Exchange server. – Nate Pinchot Sep 21 '10 at 15:03
  • For starters, do you have full permission on <Inbox> and all of it's child items? – EvilChookie Sep 21 '10 at 23:02
  • @EvilChookie Definitely. I can open the folder no problem with File | Open | Other User's Folder (as per the question). The issue is I need to add this to the favorites or some other way to quickly access it so I don't have to do File | Open | Other User's Folder to access it each time. – Nate Pinchot Sep 22 '10 at 13:38

10 Answers 10


This problem confounded me, too, but I've found the answer!

  1. Go to File > Account Settings > Account Settings.

  2. Select the Email tab and double click on your profile. Click the icon for More Settings..

  3. Go to the Advanced tab and click the Add... button. Type in the name of the user as it appears in your Exchange Global Address List.

  4. Click Apply, then OK. Close the remaining dialog box.

  5. The new inboxe(s) will appear in your folder list.

To then make it a favorite, right click the folder and select Show in Favourites or drag the particular folder (Inbox, Sent items, etc.) up to your Favorites and it will open every time.

  • Thanks. I no longer use Outlook 2010 but if someone confirms this I'll mark it as the accepted answer. – Nate Pinchot Sep 25 '12 at 22:53
  • This is the correct way to do it Outlook 2010. – Goyuix Oct 16 '13 at 18:19
  • 1
    The question specifically said without adding the mailbox to the "open these additional mailboxes" list. This answer does exactly that. When you say "Go to the Advanced tab and click the Add... button", this "Add..." button is right next to the list "Open these additional mailboxes" and allows you to add to the list. As per criselda's answer, you need to have full permissions on the mailbox in order to do this. As per the question, "user doesn't have full access to mailbox". IMO this answer should not have been accepted as the answer, previous accepted answer by NetMage is most relevant. – Kidburla Sep 13 '17 at 21:46
  • This is correct for Outlook 2016, too – Chris Adams May 10 at 13:36

From How-To Add Additional Mailbox to Outlook 2007:

You first have to provide full access permissions on the Exchange server, then follow the instructions below.

Just go to Tools » Account Settings. Click on your email and then click on Change. Click on More Settings » Advanced tab, and in the Mailboxes type the name of the user mailbox and click on Add.

After that, the user’s Mailbox will appear in your mail folders.

  • 1
    This works in Outlook 2010 as well. – MikeW Dec 17 '12 at 18:15
  • 1
    As per the question, "user doesn't have full access to mailbox". This method applied in Outlook 2010 is also exactly the method to add a mailbox to the "Open these additional mailboxes" list, which is precisely what the question asker said they DON'T want to do. – Kidburla Sep 13 '17 at 21:48

Sadly it just isn't possible in Outlook 2010. Adding another mailbox is the only way.

  • 1
    I'm marking this as the answer since this is the most correct answer to the question. – Nate Pinchot Apr 27 '12 at 15:16

Add the Mailbox as an additional mailbox. Set up Outlook delegation so that the users have read-only access.

On the AD/Exchange Mailbox rights, give the users read access.

On Sent Items, and folders other than Inbox, set the permissions to custom.

Folder Visible, Delete and Edit Items - none.

  • I don't really want to add it as an additional mailbox, due to space concerns and having an SSD. This is because Outlook forces all mailboxes to have the same cache mode settings. – Nate Pinchot Oct 28 '11 at 21:42

You need to do the following:

  • Click File | Info
  • Click Account Settings | Account Settings
  • Click the E-mail tab and select your Exchange account
  • Click the "Change..." toolbar button
  • Click "More Settings..."
  • Click the Advanced tab
  • Click the "Add..." button
  • Type in the name of the account you want to access and click OK
  • Repeat as needed
  • Dismiss all open dialog boxes
  • You may need to close and reopen Outlook for the changes to take effect (I didn't need to)

Of course, you will need permissions to the inbox first. If you need access to many inboxes, you probably want to set the inbox as a "Favorite".

I was looking for the answer to this question and found the answer here: http://bytesolutions.com/Support/Knowledgebase/KB_Viewer/ArticleId/33/Open-other-users-folders-or-mailbox-Outlook-2010.aspx

  • 1
    I think you misread the question. The question asks how to add another user's inbox to favorites without adding the mailbox to the "open these additional mailboxes" list. – Nate Pinchot Mar 23 '12 at 20:19
  • But the title of the question asks how to add it to the Favorites. I believe this is the only way. – JackAce Mar 23 '12 at 21:27

Did a couple quick tests since I was looking for the same answer.

Without adding as an additional mailbox, you cannot add it as a favorite. Use add additional mailbox and you can add it to favorites, but if you then remove the additional mailbox, the favorite drops.

That being said, I was surprised to see all the answers of "you need full access to the mailbox." That's just not true.

If you only want to see the inbox, grant the user whatever level of access you feel comfortable with to the inbox folder. Then, on the top level (where it has the email address or mailbox name), right click and select Data File Properties (2010) or Properties (2007 and earlier). Select the permissions tab. Grant only Reviewer access to the "top" of the mailbox.

Now, if you add using "Additional Mailboxes to open", you will only see the folders under the mailbox you have been granted access to.


While this will not add the folder to the favourites, you can get quick access to another user's folder by creating a new button in the menu bar pointing to this macro:

Sub OpenSharedInbox()
    Dim myOlApp As Outlook.Application
    Dim myNamespace As Outlook.namespace
    Dim myRecipient As Outlook.recipient
    Dim myFolder As Outlook.MAPIFolder

    Set myOlApp = CreateObject("Outlook.Application")
    Set myNamespace = myOlApp.GetNamespace("MAPI")
    Set myRecipient = myNamespace.CreateRecipient("<username>")
    If myRecipient.Resolved Then
        Set myFolder = myNamespace.GetSharedDefaultFolder(myRecipient, olFolderInbox)

        ' This open the folder in the current window
        Set myOlApp.ActiveExplorer.CurrentFolder = myFolder
        ' This open the folder in a new window
        ' myFolder.Display
    End If
End Sub

You can add "Other User's folder" to the "Quick Access toolbar" - follow this link for how to, which says:

  1. Open Outlook and sign in.
  2. Click the drop down arrow on the Quick Access toolbar and select "More Commands..." enter image description here
  3. From the "Choose commands from" drop down, choose "File Tab"
  4. Choose "Other User's Folder..."
  5. Click the "Add" button.
  6. Close everything. You should now see a new clickable icon in the top left that upon clicking will ask you for the name or username of the account you want to "proxy" to. enter image description here

very simple! Just use:

add-mailboxfolderpermission username:\inbox (or any other folder you need) -user mailbox -accessrights editor/owner/reviewer

Then you'll need to do this again as username only.

This will make sure you give rights to the username:\top of information store which is what outlook needs to be able to "pin" it to outlook or make it sticky without having to add the folder all the time.


This is a common request when user's have not been given full or send-as or on-behalf privilege.

The workaround is to open an additional session of Outlook and use it as the way to open a colleague's inbox. Might have been preferable it the owner gave full access on the whole mailbox rather than this, but it's only interim and not ongoing.

Open Outlook and right-click on the taskbar item and pick the 2010 outlook option, this will open outlook again and then you can use one for the additional access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.