19

When I insert a comment or make a revision to some Microsoft Word documents the comment or revision correctly reflects my User Name as the reviewer. However, after I save the document, all of my comments and revisions are converted to "Author."

This happens to some but not all Word documents. Generally, these are documents that are initially created by others (more than one) that I review, rather than documents that I created.

I am using Microsoft Word 2007 in Compatibility Mode.

What would cause this to happen in some documents and not others? How can I prevent it from happening?

18

Figured it out. Under Prepare → Word Options → Trust Center → Privacy Options in Word 2007 there is a Document-Specific Setting to "Remove personal information from file properties on save"

Unchecking this option fixed the problem. This option is only available for documents that were created in an earlier version of Office and when the option was used in the earlier version to remove personal information. That explains why the issue was occurring with some documents and not others.

3
  • +1 for research on older version. Can you elaborate the answer better. Are you saying that for documents created in 2013+ version on date after Jan 1, 2016 - the default is "strip reviewer name" or "keep reviewer name". My desired option is keep the name since the remove option renders the change tracking USELESS.
    – userJT
    Jul 8 '16 at 15:18
  • 1
    The default in Word 2016 seems to be to strip the information. Worst of all, there seems to be a bug that randomly reverts this setting. I want it disabled, but after every 5 or 6 saves, it gets secretly reactivated, so I lose all the authorship information on the next save. When I go to check in settings after that, the checkmark is back on. And the information can't be restored once it's gone, not even using Undo. Jun 1 '18 at 11:53
  • 2
    (Am writing in 2019, using Office 365.) The above setting seems to have been moved to a new place: click File > Info. Next to a square saying "Check for Issues" are the words "Inspect Document. Before publishing this file, be aware that it contains ... " followed by a list. One of the items in that list says "A setting that automatically removes properties AND PERSONAL INFORMATION WHEN THE FILE IS SAVED". (That sounds like the feature that is causing us the problem.) Then it has a clickable line saying "Allow this information to be saved in your file." That should do the trick.
    – Stephen F
    Nov 13 '19 at 0:08
7

In Word 2010, go to File->Options->Trust Center->Trust Center Settings. Then, uncheck "Remove personal information from the file properties on save"

In Word 2013, it falls under File -> Options -> Trust Center -> Trust Center Settings... -> Privacy Options. It is found under the Document-specific settings section.

7

In Word 2016 for Mac, go to the Review tab on the Ribbon → "Protect Document".  Then uncheck "Remove Personal Information from this file on save".

1
  • will this stick? for all future documents?
    – userJT
    Jul 8 '16 at 15:22
0

Word 2011 for OS X

Menu Bar ➛ Word ➛ Preferences (or press ⌘, to open application preferences)
Personal Settings ➛ Security
Privacy options ➛ Uncheck Remove personal information from this file on save

2
  • will this stick? for all future documents?
    – userJT
    Jul 8 '16 at 15:22
  • @userJT If you mean for fresh/new documents, I think so. However, any pre-existing documents will already have this either enabled or disabled. It's a document setting, not a user setting (except, I believe, on new documents created by you, in which case it uses it as a default setting) I may be wrong, but this is how I came across to understanding it. I don't use Word that often though.
    – agweber
    Jul 11 '16 at 13:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.