I have had Google Chrome installed on Windows 7 for months, and it has worked fine.

All of a sudden, I click on it to open it and it looks like it is starting (even a chrome.exe process pops into the task manager list for about a half a second, but then disappears). No error is shown, it just doesn't start.

I deinstalled chrome and tried to reinstall it but it always said, "Unknown installer error."

Then based on forum information I found, I installed google earth with chrome, which worked: chrome is now installed again, but it still will not start, just as before, it begins to start, then does not. No error is shown. Nothing in Event Viewer | Windows Logs | Application.

How can I get Google Chrome to start?


  • I downloaded and installed Safari and the same thing happens to it. Installs fine, but when I click the icon to start it, it begins to start, process comes up for a half second in task manager, then nothing happens. No error. Tried rebooting, both Chrome and Safari still don't start. Firefox and Explorer start fine. All other applications start fine.

  • I download and installed Opera which works fine.

  • When I log in as another user on my Windows 7, Chrome and Safari open fine so they don't open when logged in as the user who installed them. Odd.

  • Next day after a reboot, first only IE worked, then after awhile, but not after any significant change of mine, all browsers except for Firefox now work. When I right-click on a .htm file and choose Firefox it tells me this:

alt text

Although Firefox continues to work for other users on this machine.

  • another issue I have discovered that began to occur about the same time is when I open Microsoft Word or paste text into Microsoft Word, I get this message (although Word still opens and text is still pasted):

alt text


The issue might be due to Chrome being installed in your App data, instead of for all users.

Can you go to the following location: C:\Documents and Settings\\Local Settings\Application Data\Google\Chrome\Application (I am assuming Xp) & run the executable from there?

  • thanks, I have windows 7 and just on your suggestion I logged out as me and logged in as another user and for that user both chrome and safari work fine, why would they not run when logged in as the user that installed them? – Edward Tanguay Sep 22 '10 at 9:32
  • I think (& I'm just guessing here) that your Windows profile might be corrupt. I have seen this happen for quite a few application which save some or the other data in %appdata% folder. – Devdatta Tengshe Sep 22 '10 at 10:06
  • This is a very odd error since now after rebooting again, first: no browsers opened except IE, now after awhile all browsers (Opera, Safari, Chrome) open except for Firefox. If I rightclick on a HTML file and choose Firefox it says "There was a problem sending the command to the program." – Edward Tanguay Sep 23 '10 at 1:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.