When staring from cold my machine only sees 4GB (as shown in BIOS POST messages). If I immediately restart (i.e. before the operating system boot starts) then it will always pick-up the full 6GB (3x2GB identical DDR3 sticks)

Shuttle XPC SX58H7 Intel Core i7 920 2.66GHz Quad Core GeForce GTX 285 1024MB PCI-Express Graphics Card

I have tried reseating the memory and swapping them around with no change There are 4 memory slots and I have tried putting the sticks in all the combinations with no change I have also tried installing 2 and that will be fine 80% of the time and loose 2GB the other 20% of the time

All BIOS settings on factory standard. I have the latest BIOS update (SX58S10O) which shows as V02.67 (2010-04-09) I have the latest chipset drivers (2009-10-13)

More info: - Always happens on cold start. - Always works after quick restart if I wait for the first BIOS message. - Not tried cleaning the pins yet, good idea. - Unsure about the Hot restart, need to test

  • Does it always happen after exactly one reset? Does it still work if you reset very quick after turning it on or do you have to wait a couple of seconds? Have you tried wiping off any (possibly invisible) patina or oil from then pins on the RAM sticks with a soft eraser? Does it still have the problem if you have used the system for a while, then turn off and turn back on within a few seconds (ie, not giving it time to cool down)?
    – Synetech
    Mar 18 '11 at 2:19

Sounds like a motherboard fault, contact Shuttle as it may well be resolved by a BIOS update.

  • I have the latest BIOS update (SX58S10O) Sep 23 '10 at 21:46
  • Is the system stable the rest of the time? Or does it experience crashes often? I'd suggest running memtest see if it reports any errors if it does I'd be RMAing the barebones unit. Sep 23 '10 at 22:05

I had a similar problem with my recent build and it turned out to be a faulty DIMM. Another possibility is bent CPU pins as the memory controller for i7s have moved onto the chip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.