1

When I try to connect using Tortoise to my SVN server using:

svn://localhost/

Tortoise tells me: "Can't connect to host 'localhost'. No connection could be made because the target machine actively refused it."

How can I fix this?

I am trying to set up a subversion server on my local PC for personal use. I am running Windows Vista, with SlikSVN and TortoiseSVN installed. I previously had everything working correctly, but I found that I couldn't merge(!), apparently due to a version mismatch between the SVN client and server. Anyway... I now have the following setup:

I created a repository using svnadmin create; it resides at C:\svnGrove

C:\svnGrove\conf\svnserve.conf (# comments omitted):

[general]
anon-access=read
auth-access=write
password-db=passwd
#authz-db=authz
realm=svnGrove

C:\svnGrove\conf\passwd:

[users]
myname=mypass

My Subversion Server service is pointed to:

C:\Program Files\SlikSvn\bin\svnserve.exe --service -r C:\svnGrove

It shows the TCP/IP service as a dependency. I have also tried running svnserve from the command line, with similar results.

The below is provided by the 'about' option in TortoiseSVN:

TortoiseSVN 1.6.10, Build 19898 - 32 Bit , 2010/07/16 15:46:08
Subversion 1.6.12, 
apr 1.3.8
apr-utils 1.3.9
neon 0.29.3
OpenSSL 0.9.8o 01 Jun 2010
zlib 1.2.3

The following is from svn --version on the command line (not sure why it says CollabNet, CollabNet was the previous SVN binary that I had set up. The uninstaller failed to remove everything gracefully):

svn, version 1.6.12 (SlikSvn/1.6.12) WIN32
   compiled Jun 22 2010, 20:45:29

Copyright (C) 2000-2009 CollabNet.
Subversion is open source software, see http://subversion.tigris.org/
This product includes software developed by CollabNet (http://www.Collab.Net/).

The following repository access (RA) modules are available:

* ra_neon : Module for accessing a repository via WebDAV protocol using Neon.
  - handles 'http' scheme
  - handles 'https' scheme
* ra_svn : Module for accessing a repository using the svn network protocol.
  - with Cyrus SASL authentication
  - handles 'svn' scheme
* ra_local : Module for accessing a repository on local disk.
  - handles 'file' scheme
* ra_serf : Module for accessing a repository via WebDAV protocol using serf.
  - handles 'http' scheme
  - handles 'https' scheme

I disabled my Windows Firewall and CA Internet Security, without success in resolving the issue.

Edit

The old version of svnserve was still set up as a service after the uninstall, pointed to this path:

C:\Program Files\Subversion\svn-win32-1.4.6\bin

I edited the registry key for the service to point to the new path (shown above). Whether I run svnserve as a service, or using -d, I do not see an entry for that port number in the listing generated by netstat -anp tcp.

5
  • 1
    Is svnserve running? Netstat -anp tcp will show this; If there is a line for '3690 LISTENING', then subversion is running.
    – Kevin M
    Commented Sep 26, 2010 at 14:47
  • 1
    Is the CollabNet Subversion service still showing in the Windows Services (services.msc) list?
    – Jaymz
    Commented Sep 26, 2010 at 19:51
  • Edited to answer both of these questions. Thanks for looking at the issue!
    – RMorrisey
    Commented Sep 26, 2010 at 21:00
  • I notice that in the manual when they run svnserve, it shows the message: "# svnserve is now running, listening on port 3690". I do not get this message in my console, the console just pauses. Not sure why that is.
    – RMorrisey
    Commented Sep 27, 2010 at 3:14
  • For what it's worth, I got the old svnserve working again. Don't know why the 1.6 version won't accept connections.
    – RMorrisey
    Commented Sep 29, 2010 at 3:50

2 Answers 2

2

Hudson cannot connect anonymously to svnserve on Windows 7 64-bit with the standard defaults. The following parameters added to the command line were successful:

svnserve -d --listen-port 3690 --listen-host 127.0.0.1 -r svn-repos
2

On Windows 7 Professional 64-bit, using SlikSvn, I could connect to svn://localhost/, but not to svn://127.0.0.1/.

I then found I could connect to svn://[::1]/ which I addressed by adding

::1 svn

to C:\Windows\System32\drivers\etc\hosts.

Now, svn://svn/ works fine.

Also, the command:

netstat -anp tcp

will not show IPv6 information. To view IPv6 connections, use:

netstat -anp tcpv6

Therefore, to see if there is an listener on port 3690, use:

netstat -an | findstr "3690"
1
  • Interesting point (thanks), though not directly related to the question.
    – Wolf
    Commented Sep 28, 2015 at 9:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .