2

I have the Dell Mini 9 with Ubuntu. After an auto-update a few weeks ago, whenever I try to launch Firefox I get the message:

Failed to execute child process
No such file or directory

So I tried uninstalling it in the Add/remove applications menu, then I told the command line

sudo apt-get install firefox

but it responds by telling me that Firefox is already the newest version. So I try installing it again in the add/remove menu, and it claims that the operation is a success... except it still doesn't work after that.

Is there a more thorough way of deleting the program? I'm not too experienced with Ubuntu and unsure how to proceed.

0

Try removing and installing again

sudo apt-get remove firefox 
sudo apt-get clean
sudo apt-get update
sudo apt-get install firefox

If still you're getting an error try launching Firefox from console firefox

and update the question with any messages that's coming on screen

| improve this answer | |
  • sudo apt-get remove firefox worked fine. sudo-apt-get clean appeared to do nothing--i hit enter and it just goes to the next line without giving any feedback at all. then update worked fine and install worked fine, but afterward i tried to launch to program again and got the same error message from before – user50626 Sep 28 '10 at 3:19
  • The same error comes when you try to launch from the console ? – Sathyajith Bhat Sep 28 '10 at 3:23
  • oh i just looked up what that meant. it worked! thank you. – user50626 Sep 28 '10 at 3:29
  • Can post an answer on what exactly you did ? It'll help others. – Sathyajith Bhat Sep 28 '10 at 3:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.