I am using filezilla and it seems very often if I transfer a large amount of files it will tell me some files is already there with half the size of the other one and ask about replacing. Problem is I am transfering to an empty folder. I am 100% positiv there is nothing in there.

What am I missing in FTP that could be causing that?

  • 1
    Is Filezilla disconnecting during the transfer? That could cause a partial file upload. – steve.lippert Sep 29 '10 at 15:44
  • @steve.lippert thats an interresting idea. Indeed Filezilla keeps disconnecting everytime I transfert something for more then a minute. I am trying to test that and for the first time ever he stays connected ha ha. You might want to post this as an answer so I can vote and accept it if it turns out it was that. – Iznogood Sep 29 '10 at 15:53
  • If it is disconnecting; why is it disconnecting? May be... sometimes a server will only accept a max number of simultaneous connections (eg. 8), but FileZilla will I think (by default) connect as many times as possible. – MrWhite Sep 29 '10 at 16:05
  • @w3d No idea why. Ill check into that. – Iznogood Sep 29 '10 at 19:16
  • @Iznogood Have you tried another FTP client (not that there is anything wrong with Filezilla)? Are you able to try it on a different connection (ie. not via your usual ISP)? – MrWhite Sep 29 '10 at 19:53

It seems like Filezilla is disconnecting / getting disconnected and causing the partial file upload.

Go into "Edit" -> "Settings" -> "Transfers" and tune it down to one and try the test again. It may be that the server doesn't like simultaneous transfers. If it is set to one then you may have another issue.

If it works on one transfer at a time tune it up to two or three and try again. You can keep testing to find the max.

It could also be that the server doesn't want you to stay connected for long, in which case one fast connection would be better than many slower connections.

  • Oh well I don't think its that anymore. I just changed the setting to one connection at a time. Connected to my ftp and started a tranfer and a couple of seconds in it asked again about replacing a file. Just noticed it was the same file. Always that one file. Nothing special about it its a normal php file. – Iznogood Sep 29 '10 at 17:31
  • Seems like the FTP server is having an issue then, if it is disconnecting you mid-way through a php file transfer. I'm guessing you can upload that file pretty quickly and it isn't taking minutes to do. – steve.lippert Sep 29 '10 at 18:20
  • Problem is the ftp server is on a shared hosting account at IWeb. I would expect there setup to work. I tried different things and its always the same files but onlky if I transfer a lot of them. If I chose just a small number of files they all upload succesfuly. Whats funny is that as far as I can remember I have had problems like that on any ftp. – Iznogood Sep 29 '10 at 18:23
  • This is still a bug 9 years later. It's not a disconnection issue as it seems to upload a file with completely different modified date info to the actual file. – user2924019 Jul 8 '19 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.