I often (like just this morning) have a situation where I need to delete or replace a file that may be located in folders like C:\Windows. When I try to do this I always get access denied. Every resource I can find shows me step by step how to modify the permissions, I already know how to do this. The problem is when I try to modify permissions and it tells me access denied. I don't have permission to modify the permissions! This happens even when I launch Windows Explorer or CMD as Administrator (my account is Admin), and even when I tried using cacls. UAC is at the lowest possible setting so it never bugs me. What's the deal Windows 7? Why can't I own all my files? It's so annoying that sometimes I actually boot Linux to go edit/modify a Windows file! Ok rant over, but can anyone solve this for me?

up vote 3 down vote accepted

Have you tried taking ownership over the file. Instructions for hand right click menu here.

  • tried this to no avail, the take ownership option appears in most folders: i.imgur.com/qOkC9.png however not in the Windows folder: i.imgur.com/Y8pd4.png – BigOmega Sep 30 '10 at 17:03
  • HOWEVER, I was able to see the Take Ownership option while clicking on the Windows folder itself, I hope it's OK that I now own the whole Windows folder! Now I can edit the files I wanted, THANKS! – BigOmega Sep 30 '10 at 17:11
  • and one more time, I wish I could see what Take Ownership was doing so I knew how to do it manually, any ideas on how to view this? – BigOmega Sep 30 '10 at 17:17

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.