I've been using Remote Desktop to connect from a Windows Vista machine to a Windows XP machine. Everything used to work fine, but a few weeks ago I found that I could not drag things with my mouse. I can click on things just fine, but I cannot move or resize windows or select text with the mouse. I did some experimenting, and it seems that the remote machine behaves as though it gets a mouse up event shortly after it gets the mouse down event, even though I am still holding the button down. On both machines, things work fine outside of Remote Desktop.

I did reinstall the OS and software on my Windows Vista machine a couple of months ago, and that might have been about the same time that this problem appeared. I don't frequently use Remote Desktop, so I can't be sure.

Does anyone have any suggestions?

  • I am seeing what seems to be the same problem, using remote desktop from Vista to Windows 7. Have you found a solution? – K Robinson Aug 30 '11 at 3:00

Do not have a definitive answer to the cause of this, but in my experience it usually appears to be a lock on one of the keys, hindering mouse or keyboard operations

  • Ctrl
  • Alt
  • Shift
  • Windows Start

When that is the case, pressing those keys in the Remote desktop usually "frees" them. If that still does not work, log off the existing session and logon to a fresh one. Annoying but it restores the mouse drag.


To add further information, I have in very recent cases see my Windows 7 computers exhibit similar problems. Odd thing is, mouse drag works for moving windows and selection boxes, but just not for dragging icons or items across areas. When i log onto the physical session instead of Remote desktop, i observe the same problem, which still has to be resolve via a log off. Seems to be more of a desktop session problem per se than a Remote desktop issue.

  • Thanks. I no longer have a windows vista machine from which I can test this, so I'm afraid I can't confirm whether this solved the problem. Hopefully your answer will be helpful to someone. – Paul Lynch Apr 19 '11 at 17:16
  • Added an update to recent things i observed. – icelava Apr 20 '11 at 14:13
  • I use Remote Desktop from a Vista machine to a Windows 7 box, and I am seeing the same problem, only over remote desktop. I don't continue to have the problem when I log in to either computer physically. I already have admin privileges on the remote computer. It's consistent, and thinking back on it, I have rebooted both machines since I saw the problem first--so rebooting hasn't solved the problem. – K Robinson Aug 30 '11 at 3:02
  • +1 that logging off and on fixes it, at least until it happens again. – goodeye Jul 12 '12 at 20:21

I solved this problem by simply log into Vista as an "admin". If you login as an "admin" and run Remote Desktop, everything (including dragging mouse) works just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.