The scenario: I have an email account on a server that I also have ssh access to. Normally I check this account via IMAP in Thunderbird (currently 3.0.8 on Ubuntu) and IMAP on my phone (Nexus One, default mail app). Occasionally I use a web interface (Squirrelmail 1.4.20).

Earlier today I used Alpine locally on the mail server to read a message. This was the first time I had ever used Alpine with this account on this server. Afterwards, all of my old mail disappeared from both IMAP clients and the web interface. The mail is not gone; it shows up just fine in Alpine, and it's still in the mbox in my home directory on the server.

However, I cannot figure out how to get it to show up again in any other client. I've tried un- and re- subscribing to folders in Thunderbird as well as creating a new account. I'm assuming Alpine changed something, but I can't see what or how to undo it.

Note: If it wasn't clear, new email (since using Alpine) shows up as expected in Thunderbird, etc.

  • When you say that it's still in the mbox of the home directory on the server, do you mean that it's from that mbox that you would connect to using IMAP? My first guess is that Alpine has downloaded the mail to its directory somewhere using POP. – fideli Oct 1 '10 at 11:18
  • That was my first thought, but it doesn't seem to be the case. All my mail is still in /home/<username>/mbox but not visible via IMAP. I was using Alpine locally on the mail server (via ssh) so I don't think it was using POP3 or anything like that. – terru Oct 1 '10 at 19:38

If Pine is using your local mbox file to move messages from /var/spool/mail to it, you can stop this behavior by adding disable-these-drivers=mbox to your .pinerc. In case you are having problems with the old maildir patch and you do not use maildir, simply add maildir there too.

Your old mailbox is in /home/username/mbox (aka ~/mbox).

Please note, now pine won't see your mbox file. from your home directory type cd mail, then type ln -s ../mbox MyOldMailbox. Now pine can see your old mail in the MyOldMailbox file. IMAP clients will also be able to see the MyOldMailbox folder. You might want to call it 1MyOldMailbox so it shows up at the top of your mailbox lists.

(from: http://patches.freeiz.com/alpine/alpine-info/tips/index.html Tip 84)

  • 1
    I actually fixed this a while ago, but this is essentially it. At some point, the mail setup on the server changed to storing mail in /var/spool/mail rather than /home/username/mbox. Alpine had moved all my mail to /home/username/mbox, but IMAP clients, etc. were looking at /var/spool/mail. – terru Apr 11 '11 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.