I recently upgraded my workstation from XP SP3 to Vista Business, and during the upgrade Windows moved my old C:\Windows directory to C:\Windows.old. I got all of the stuff I needed out of that folder, but there are six "undeletable" files there so I cannot remove it. They are:

Windows.old\Program1\Adobe\Reader 9.0\Resource\CMap\Identity-H
Windows.old\Program1\Adobe\Reader 9.0\Resource\CMap\Identity-V
Windows.old\Program1\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelper.dll
Windows.old\Program1\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll
Windows.old\Program1\Common Files\Adobe\Acrobat\ActiveX\AcroPDF.dll
Windows.old\Program1\Common Files\Adobe\Acrobat\ActiveX\pdfshell.dll

Whenever I try to delete the files either through explorer or a command line, I get a permission denied error. I have tried to grant myself full permission on the files, but again, permission denied. I don't even have acrobat installed on my Vista machine, and I uninstalled Adobe updater. However, I still can't manage to get rid of these files. How do I nuke them for good?

Edit: I was able to take ownership of the files, but I still can't delete them. Renaming them did not work, as I was denied permission to do that as well. I'll try booting up in safe mode and getting rid of them there.

Edit II: Booting up into safe mode did not allow me to delete the files. Bummer.


You'll want to first take ownership of the files, which is easiest when you add Take Ownership to the right-click menu.

Once you've done that, you can do one of the following:

  • Use Unlocker to remove whatever is locking the file, and then delete it.
  • Use Boot Deleter to delete it when you reboot.
  • Try and rename the file, sometimes you can rename them when you can't delete them. Once you reboot, you can delete it.
  • Try and delete it from safe mode.
  • Delete it from the command prompt, usually safe mode works the best.
  • +1 for Safe Mode. Previously when I've had stubborn to delete files, Safe Mode has saved the day.
    – Pauk
    Aug 10 '09 at 10:59

I had a similar problem deleting a seemingly empty folder.

These are the steps I had taken:

  1. Use Cedrick Collomb's Unlocker to remove any locks
  2. Use Unlocker to delay delete on reboot
  3. Turn off windows search service to prevent indexing of folder
  4. Deleted user rights of "unkown user" (rights from previous OS)
  5. Took ownership of folder
  6. Rename folder to delete
  7. Delete from command line with admin rights
  8. Delete in Safe Mode

None of these solutions worked for me.

My solution:

It then occurred to me that the file system might have become corrupted. I therefore ran check and repair of the file system by running

chkdsk /f
from the command prompt. After a reboot I was finally able to delete the folder.

  • Nick, did none of the answers on this page help you? If one did though, please let everyone know. Thanks.
    – Jaspio
    Nov 3 '09 at 13:36

Try taking ownership of the files and then deleting them.


Just guessing here, but as your SU name is Nik and that user says Delade, I am guessing this is a ACL issue.

Here is a very quick and simple way to do it - http://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/

Otherwise, right click and go to properties, go to security and add your name with full control.

  • It says "Delade filer" because it's a Swedish version of Windows; it's not actually somebody's username. ;) I forgot about this when I pasted in the paths, but I've edited my original question to use the English translations and avoid any confusion.
    – Nik Reiman
    Aug 7 '09 at 7:45
  • Well, I feel like a idiot now! Aug 7 '09 at 7:49

If it's not:

  • a problem of ownership => Permissions properly sets (the how-to-geek take ownership should do it)
  • locked by another program or possible to delete them at reboot => FileASSASSIN or the previously mentioned Unlocker should help you (or Lock Hunter for Windows7)
  • a hard disk problem => try to fix it with chkdsk /F or another HD scan/repairs program

It could be a corrupted filename, so you could try Delete Doctor (freeware) or delinvfiles (shareware, but more features) to delete the files with short or UNC filenames.


Another alternative is using a Linux Bootable USB stick. This is especially convenient if you already have one lying around. Sometimes taking ownership of files does not work. The nice thing is that this also works if you cannot take ownership.

Step by step:

  1. Create a Linux bootable USB stick (for instance ubuntu: http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-windows )
  2. Boot from the USB stick
  3. Navigate the folders and delete everything you want.

Sometimes, especially with external drives, this can be simply resolved by changing the ownership properties in the security tab of the properties of the file or folder in question. While this is, by far, the easiest solution, for more problematic situations, it may not always work.

  • Right click on the file or folder in question
  • Choose 'Properties'
  • Click on the Security tab
  • Click on 'Edit'
  • If 'everyone' is not present Click on 'Add'
  • Type 'everyone' (without quotes) and press OK
  • In the lower part of the dialog, choose 'Full Control' and then press OK

    Try deleting again.


Also, sometimes it is necessary to do this process with the parent folders containing the files in question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.