The optical drive on my Macbook seems to have some sort of blockage. When I try to insert a disk the disk seems to be hitting something inside the drive on the right side (the side nearer the monitor). Thus disks do not fit into the drive. This problem occurred a few weeks ago, but then miraculously fixed itself. It felt like I had managed to maneuver the disk over the blockage. Now the blockage is back and I can't get any disks into the drive again. Anyone ever encountered this problem before? I probably need to open up my Macbook, huh.


I solved the same problem by forcing an eject through commandline. Open a terminal and type

drutil eject
  • 1
    Great, that worked after two or three attempts. – DaG Sep 20 '11 at 17:05
  • Doesn't eject for me. – Timothy Swan Nov 7 '17 at 6:25

This may not be the best solution, but I had that problem a few months ago on my Late 2008 MacBook and I just slowly but forcefully pushed a disk in and out to coax the mechanism to release. That was the best solution that I read online (I can't seem to find anything now, the search terms evade me).

Apple user forums also recommend trying an SMC reset:

my optical drive is blocked. No CD/DVD inserted. I tried to insert a disc. not possible. feels like a arm avoid a insert of the disc.
when booting the mac the drive tries 3 times to eject something. (even its empty).

You could try an SMC reset … see http://support.apple.com/kb/HT2801 and http://support.apple.com/kb/HT3964

  • Yes!That worked for me too. – milse Oct 1 '10 at 2:53
  • Though, that doesn't really seem like the best solution for the problem. It feels like something's eventually going to snap off. Oh well. – milse Oct 1 '10 at 2:55
  • On a separate note, I'm not sure what resetting the SMC is supposed to do. I tried it and nothing changed. No whirring noises, no clicking. I'm not really sure it worked. – milse Oct 1 '10 at 2:57
  • Thanks again. I'd vote for you, but then I'd need to register... – milse Oct 1 '10 at 2:58
  • It's the thought that counts. Good to hear that it worked. – fideli Oct 1 '10 at 11:24

OK, I finally solved my problem. There was definitely some sort of rotor that was elevated near the middle right of the drive preventing me from inserting a disk. The drive was obviously in a whacked state thinking there was a disk physically in the drive even though there obviously was no disk in the drive.

SO! The following did NOT work: system reset, sticking in a disk and banging it, forcing it, pushing it, tapping it, etc., rebooting and holding down the mouse key - EVERYTHING I read online.

This DID work: Get a credit card and slide it into the drive below the rotor near the front edge of the drive slot (away from the screen) - it will go past the blocking rotor near the back. At that point if you move it back toward the screen you can feel the rotor still blocking. Now gently bend the credit card upward (toward the keys) while sliding it back (toward the screen) - it will pass over the top of the rotor. Now hold the credit card where it is and get a CD and slide it into the drive with the credit card shimming it over the rotor. The disk should go in as far as you want it to. I kept out just a tiny edge - enough to hold onto with my fingertips. Once it was in that far and inserted past the rotor, that was enough to reset whatever sensor on the drive was messed up and the motor came to life, the blocking rotor dropped and everything resumed functioning. I did all this while the machine was running with no stupid restarts etc.

Not the answer you're looking for? Browse other questions tagged or ask your own question.