I built a new computer last night but I'm running into an error that's new to me and keeping me from installing an operating system. Long story short, the system can boot off a CD but once loaded, the installer application can't find my CD drive.

Long story long, I started with Windows 7. It got up to expanding or extracting data and then got stuck at 0%. Other people had this problem too, so I assumed it was a bad burn. I then tried installing debian off of known good media. It was unable to mount the CD drive. I tried knoppix too and it ran into similar problems, dumping me into a very limited shell.

I tried this with another CD drive and another IDE cable. No luck. Both drives and my original IDE cable worked fine on my previous build.

The motherboard in question is an ASUS M4A88TD-V. Its BIOS didn't have a lot of relevant options. Interesting enough, the boot order section listed my CD drive both by make/model and as ATAPI CDROM. Not sure why it would do that.

I'm going to try installing from USB media. I don't know if I should RMA the board yet, but I figure if I can get an OS installed at least I'll be able to run some diagnostics on the board.

Oh, one last thing. I read about another user with a similar problem. They ended up needing a new power supply because the previous one was underpowered. Mine is 550 watt and the manual led me to believe that that would be enough. I unplugged two of the four hard drives to see if that helped. Still can't install from CD. If I don't find any other suggestions I'll try pulling the video card next.



Turns out the VT6330 Firewire/IDE controller isn't recognized by older linux kernels. You need 2.6.33 or higher, with the pata_via (or was it via_pata?) module enabled. The new Ubuntu 10.10 should have it. No idea why Windows wouldn't install, but I'm going to blame it on a bad burn and be done with it.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.