46

I have this MS Ergo Natural Keyboard 4000 on windows 7, with the SetPoint Intellitype Software. I want to change the action of the center zoom to make it sroll. I'm some old versions of Firefox it worked that way, until I update it to FF 4 Beta 5.

Is there any way I can change that action? I don't use the zoom at all.

Thanks in advance

5
  • Um, SetPoint is Logitech software, not Microsoft. Did you mean IntelliType? – MBraedley Oct 4 '10 at 2:07
  • 2
    so many people search for this that my query was autocompleted by Google (i.imgur.com/NoHmPrW.png) and yet nobody in Microsoft ever thought it might be a good idea?! – georgiecasey Mar 24 '15 at 5:11
  • 1
    Anything for Mac users? – Sherzod Apr 28 '15 at 17:19
  • I installed driver for the keyboard, but dont have any "microsoft IntelliType pro" directory. Where else should I look for that commands.xml? – Buksy Sep 25 '19 at 7:45
  • 1
    @Buksy or anyone else hereafter: Microsoft has done some renaming and updating. Look for: C:\Program Files\Microsoft Mouse and Keyboard Center\ – Justin Dec 7 '20 at 19:01
36

I know this is an old question but I had to work this out for myself so it's worth spreading:

Unfortunately, the Ergonomic keyboard config utility doesn't allow you to change the settings for the centre zoom button. In order to do so, you will have to edit the C:\Program Files\Microsoft Intellitype Pro\commands.xml file manually. (For computers running the more recent Microsoft Mouse and Keyboard Center the path is C:\Program Files\Microsoft Device Center\commands.xml)
N.B. the contents of this file change depending on which version you have so make sure you have the same version as me before you try. The version number can be found at the top of the Commands.xml file. My version is:- 8.0.225.0 If this explanation gets too basic, it's because I don't know how much you know about Windows or config files.

First thing to do is make a copy of the Commands.xml file, that way if you mess up it's repairable. Simplest way to do this is to copy and then paste it straight back into the same directory, Windows will call it Commands - copy.xml. If you mess up, just delete Commands.xml and rename Commands - copy.xml to Commands.xml

Second, open the original file to edit it (right click -> edit) and insert the following lines in between 2 entries towards the bottom of the file (under the <ALL> element, which comes last):

    <Application UniqueName="MozillaUIWindowClass" AppName="Firefox">
        <C319 Type="6" Activator="ScrollUp" />
        <C320 Type="6" Activator="ScrollDown" />

The end of your commands.xml file should end up looking something like this:

    <Application UniqueName="GeminiWindowClass" AppName="RealOne Player">
        <C309 Type="5" KeySeq="alt F4" />
    </Application>
    <Application UniqueName="MozillaUIWindowClass" AppName="Firefox">
        <C319 Type="6" Activator="ScrollUp" />
        <C320 Type="6" Activator="ScrollDown" />
    </Application>
    <Application UniqueName="GMail" AppName="GMail">
        <C204 Type="5" KeySeq="ctrl y" />
        <C309 Type="5" KeySeq="ctrl w" />
        <C319 Type="6" Activator="IEZoomIn" />
        <C320 Type="6" Activator="IEZoomOut" />
        <C401 Type="0" />
    </Application>
    <Application UniqueName="LiveHotmail" AppName="Live Hotmail">
        <C204 Type="5" KeySeq="ctrl y" />
        <C309 Type="5" KeySeq="ctrl w" />
        <C319 Type="6" Activator="IEZoomIn" />
        <C320 Type="6" Activator="IEZoomOut" />
        <C401 Type="0" />
        <C900 Type="5" KeySeq="ctrl r" />
        <C901 Type="5" KeySeq="ctrl shift f" />
        <C902 Type="5" KeySeq="ctrl enter" />
    </Application>
    <Application UniqueName="Picasa" AppName="Picasa">
        <C319 Type="5" Activator="pageup" />
        <C320 Type="5" Activator="pagedown" />
    </Application>
</ALL>

Now I know that there is already a Firefox section in this file near the top, however, when I tried inserting the scroll entry up there it wouldn't work, as though some setting further down was overriding the entry. Go figure.

To get the zoom to work correctly in Firefox use the following lines instead:

<Application UniqueName="MozillaUIWindowClass" AppName="Firefox">
        <C319 Type="5" KeySeq="ctrl +" />
        <C320 Type="5" KeySeq="ctrl -" />
    </Application>

Good luck.

5
  • THanks! I'll try it tomorrow 'cause i'm not with the keyboard today.... – josecortesp Oct 5 '10 at 4:41
  • 3
    My driver just updated to Microsoft Mouse and Keyboard Center, and I lost this functionality :( I do not have a Microsoft Device Center folder like you mention, but a Microsoft Mouse and Keyboard Center. However, changing the commands file that exists there hasn't brought the scroll functionality back. Anyone else having this issue? – Ben Sep 18 '13 at 13:07
  • 3
    unless you have some overriding configuration for a specific application (for example Visual Studio 2010 or Chrome), you can add same lines under <Application UniqueName="StandardSupport"> tag to support anything else. My two cents. – keremispirli Feb 3 '14 at 15:19
  • 1
    I missed the bit about <ALL> element and wasted quite a few tries editing other parts of the file. %) Also just edited UniqueName="StandardSupport" section instead of adding new entries. – Rarst May 6 '16 at 18:51
  • This answer is great. I wonder what you meant by "Old question". First I don't think there's anything that can make a question old and second you replied one day after the question was posted. – KeyC0de Mar 4 '20 at 12:48
21

You can also use notepad++ and the Replace Dialog(Ctrl+F and select Replace tab). Check "Regular Expression" in the bottom left side of the dialog and use these to remap the zoom key:

Find what: <C319 .* />
Replace with: <C319 Type="6" Activator="ScrollUp" />

Find what: <C320 .* />
Replace with: <C320 Type="6" Activator="ScrollDown" />

Side note: the process is now called itype.exe. Close the process and restart it(Task Manager->File->Run new task-> "itype.exe") for the changes to take effect.

5
  • I found this regex idea in another site and it caused errors with the intelliType application (win8, v 8.20). This tutorial worked for me, though: pchenry.com/Home/tabid/36/EntryId/77/… – rdmptn Dec 13 '13 at 14:50
  • Works, but scrolling is very slow in most applications, including Firefox and Windows explorer. Any idea how to improve that? – angularsen Nov 17 '14 at 9:32
  • Maybe try to adjust the "zoom speed". Unfortunately i don't have the keyboard anymore to test this (spilled beer on it... bad idea) but maybe someone else has and idea. – Andrei Nov 18 '14 at 14:54
  • Adjusting the zoom speed worked for me. – kindall Jul 14 '17 at 21:32
  • This seems to have worked for me. One aspect I find annoying is that scrolling is determined by the location of the mouse, not which program is selected. That's a useful feature if you're scrolling with the mouse, but not so helpful if you're trying to scroll using the keyboard. – filups21 Jun 5 '19 at 15:48
12

To build on top of Tog's answer, here is a script that does the replacements automatically for you. It is basically an XSL transform applied to the commands.xml file. And it does the backup for you.

http://teamagile.com/downloads/ZoomToScroll.zip

Look inside for the instructions. Keep in mind, you may have to run the script inside an administrator command prompt if you have UAC enabled.

I tried it on a v8.20.469.0 file and it worked as expected.

This script is not made by me, it's made by Roy Osherove. See original source

2
  • 1
    If you have Microsoft Mouse and Keyboard Center unzip the files here instead: C:\Program Files\Microsoft Mouse and Keyboard Center. make sure to run the file as admin. After that, run mskey.exe -> "action" -> "close intelli pro". After it is closed, you can click on "actions" again and "Launch Keyboard Control Panel" -> Open "Microsoft Mouse and Keyboard Center". It should work now. – Gustavo Puma Apr 6 '16 at 23:30
  • This is great, because I used Tog's and Andrei's advice on the Microsoft Mouse and Keyboard Center commands.exe and itype.exe stopped working. However it did work on Intellitype Pro (which is an older version). However I used the script you suggest here and now everything works. Thank you all! – KeyC0de Mar 4 '20 at 13:36
8

My file version is 8.20.469.0 and the solution for version 8.0.225.0 did not work for me.

What worked however is

change:

<Application UniqueName="MozillaWindowClass" AppName="Netscape">
    <C319 Type="5" KeySeq="ctrl add" />
    <C320 Type="5" KeySeq="ctrl subtract" />            
</Application>

to:

<Application UniqueName="MozillaWindowClass" AppName="Netscape">
    <C319 Type="6" Activator="ScrollUp" />
    <C320 Type="6" Activator="ScrollDown" />            
</Application>
2
  • 1
    Thank you very much. Yes, changing the "Firefox" setting didn't work for me, but changing this "Netscape" setting works. – wujj123456 Sep 14 '12 at 2:36
  • It seems to be linked to the UniqueName. The Autiit Window info confirms the WindowClass of Firefox is now "MozillaWindowClass" again. The correct AppName would be "Mozilla Firefox," but it doesn't seem to care about that. – Dan Jul 17 '18 at 19:58
5

yop83's answer did the trick for me, but I did have to restart the driver for it to take affect. You can do that by launching mskey.exe -> "action" -> "close intelli pro". After it is closed, you can click on "actions" again and "Launch Keyboard Control Panel".

Not the answer you're looking for? Browse other questions tagged or ask your own question.