Looking through my Microsoft Update log, for the past three weeks, the same update has been downloading and successfully installed by windows updater. The update is Security Update for Microsoft Virtual PC 2007 (KB969856). Obviously I have Virtual PC installed, and I am running XP Pro SP2. How can this be stopped?


I believe I have resolved this issue on my own, though I would love to know if there are other ways to resolve it. Here is what has worked for me now for almost 24 hours and through a manual search for updates.

After deciding to give up on Virtual-PC, and going to uninstall the program, I found I had two copies installed, Virtual PC 2007 and Virtual PC 2007 SP1. I'm not sure how I ended up with both, but I had. I uninstalled both, and then reinstalled SP1. I was almost immediately prompted for the same update again (KB969856), but after installing that and restarting, I have not been prompted again. Like I said, I'm not sure how I ended up with this particular configuration, but hopefully it will help others if they run into the same issue.


Sometimes this happens when an update silently fails (appear to update OK as far as WindowsUpdate can see, but doesn't mark itself as installed so it doesn't get tried again next time).

Check the logs to see if an error is being reported there: right click "computer", select manage, open the "event viewer" tree, and have a look for related messages in the log you can see there.

Also, try getting downloading the update and installing it manually - this sometimes shows up the error that is otherwise being swallowed by WindowsUpdate, giving you a clue as to what went wrong.

  • I had done both of those, but from everything I could find it was being successfully installed. But those are definitely good suggestions. – Timothy Carter Aug 7 '09 at 14:33

Try downloading the update and install it in Safe Mode. See : http://support.microsoft.com/kb/910339/

  • @Jerry: Windows 7 Ultimate does not allow the Windows Installer service to run in Safe Mode – Steve Sep 5 '11 at 4:12

I have seen this happen before when there is not enough free disk space to run the update.


Had this happen once, turned out that the Anti-Virus/Firewall (Norton) was blocking access to the actual download even though Windows could get out to the internet just fine. Was also blocking the Java updater and a couple of other auto-updaters. I removed Norton, got all of the updates done and then installed a different AV software package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.