I actually want to set my company's outlook (only way I can log into my company email) to forward every single message, sent or received, to my personal account automatically.

I can do it manually, but outlook rules are not working. And it's not a problem on how I'm setting the rules because it's just 1 plain simple rule.

In fact, when I go on "Manage Rules" and "Run the Rules Now", the messages even go to the "sent messages" folder, and it says "this message was auto forwarded" or something like that. But it never reached the destination.

So, how can I diagnose the issue? I get no errors, the messages just don't go!

How can I find where is the error? Is there a place where I see all outlook activity? There are just too many options in this crap, and I can't find anything on the net to help me with this.

Any help appreciated!

edit: I've created a new rule to CC all my sent messages, and I could verify that one just worked! While, of course, the incoming rule still doesn't.

On a further test I also couldn't receive an external message (and have no error or postmaster issue sending that test)! o_O

So, maybe the question here should actually be "how am I even able to send messages out?". :o Because looks like it's all locked up.

Freaking MS Exchange, Outlook and their thousand options with none actually useful...

  • 2
    Is there a corporate policy that prevents forwarding mail in this manner? – Dave M Oct 6 '10 at 21:12
  • @DaveM I don't know. Is it possible to do something like that? How can I check? – cregox Oct 6 '10 at 21:55
  • There are a large number of options in Outlook that can be controlled by Group Policy by your corporate IT department, I'm not 100% sure rules/alerts can be but it's pretty likely. – chunkyb2002 Oct 6 '10 at 22:35
  • @chunkyb I think it's also pretty unlikely this small company would have done so. Seems like it's some lack of configuration or policy to try and restrict receiving / sending email outside the company. But web is all open, and till 20 minutes ago I wouldn't even consider this option, because even sending mails (from outlook) are working! Also note manually applying the rules throw mails on the "sent mail" box and so does the automatic rule for sending mails - just the automatic rule for receiving seems to not apply. – cregox Oct 6 '10 at 22:49
  • To know if there is something preventing forwarding of this type, ask the person(s0 that manage teh Excahange Server or pssobly a mail appliance that could do data loss prevention. In a small company, the blocking could be a paid service. Some mail security appliances/servcies will block Spam, malware and do Data Loss Prevention. It could alos just be an incorrect setting on your server and the admin would be happy to know that. – Dave M Oct 7 '10 at 11:20

OK if you can send e-mail to external domains using Outlook normally and your forwarded e-mails using the rule are appearing in the sent items folder then somewhere between the exchange server and the internet your mails are being intercepted and blocked.

If you cannot send e-mails externally then it could be a configuration issue on the exchange server or a deliberate choice to restrict external mail traffic (seem unlikely).

A common issue while configuring exchange is to choose to relay your mail from the exchange server directly but not setting it up properly (normally not publishing Sender Policy Framework http://www.microsoft.com/mscorp/safety/technologies/senderid/default.mspx). This causes mail to be rejected by certain e-mail providers (hotmail.com is one prime example)

It may also be as simple as an aggressive spam filtering depending on your personal e-mail provider.

| improve this answer | |
  • That comment about exchange miss-configuration can be very valid. I've actually managed another SMTP Server before and had many, many problems with those minor adjustments and lack of SMTP standards - every mail host handles SMTP their own way, based on different rules. It's a huge mess! I'll try check that with the sysadmin in here, if he's that open. Thanks for the hint. Be back soon. :) – cregox Oct 7 '10 at 14:03
  • Well, much have happened, maybe I won't have another chance to try out your suggestion. So, for now, and in case this question dies, I'll just accept this. ;) – cregox Oct 8 '10 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.