I have an Asus Eee PC 901. I want to install Win7 on it and at the same time, re-partition it into one large drive (it's currently complaining about HDD space issues).

I've downloaded a Win7 ISO and used the Windows 7 USB/DVD Download Tool to create a bootable USB stick from it (16GB Kingston Datatraveller II).

My Dell Inspiron 6400 laptop will boot from the USB drive with no problems, however the Eee PC will not. I have changed the boot order to start with the external drive, but it still boots straight into WinXP from the internal SSD. I have tried all USB ports on the Eee PC (there are reports that only the port on the left hand side will work), all to no avail.

Has anyone else experienced this issue? Could there be something wrong with the USB stick that means the Eee PC cannot boot from it even though my Dell laptop can?

1 Answer 1


I had the same problem a couple of weeks ago. It turned out that mine Eee (model 1018p to be exact) didn't understand newer versions of FAT. Try to compile USB stick to FAT16, copy boot image (memtest is great for the test purposes as you don't need to jiggle GBs of data) and try once again. Also, SDHC card works fine.

  • Thanks for the advice. I don't have an option to format as FAT or FAT16 - only FAT32, exFAT or NTFS. I've tried FAT32 and NTFS and neither worked. I'll try exFAT, then I'll do the whole thing over on an SD card and see if that's any better. Oct 7, 2010 at 8:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .