I have a PATA disk from a 386 laptop (1995?) which I would like to get files off.

It is a Seagate 9096A, and is working. Using the old laptop is not possible.

I have tried a USB - 2.5" PATA adapter, but it failed to properly interface with the drive. In linux, it reported the size as 0xffffffff (2000 GB!), and in Windows XP, it failed to show up in Drive Management. A dd from the disk failed, and tried to create a 2TB file.

I have tried it in a Pentium-M (2005?) laptop, but it is not recognised by the BIOS.

Any suggestions? Why isn't it working? I assume that the PATA / IDE instruction set has changed since then.

Edit: To future readers; it seems that the laptop BIOSs didn't support old IDE standard versions, and the drive in question comes from the early days of IDE standardisation. Fortunately, it worked with an adapter, see the Answer for details.

  • I'd try hooking it up internally to a similar era machine, say a 486 or Pentium, with a network card to move the data to a newer machine. Your issue is probably the USB adapter, incidentally.
    – user3463
    Oct 11, 2010 at 21:34
  • Yes, that will be my approach, but I will need to buy a 2.5" to 3.5" converter. I agree about the USB adapter. I was hoping for an indication as to what age of a machine I will require. Why didn't you post that as an answer? Oct 11, 2010 at 21:39
  • Because it didn't meet my internal quality checks for a proper answer.
    – user3463
    Oct 11, 2010 at 22:27

2 Answers 2


Most 2.5" adapters can be connected backwards, did you try it both ways? It probably is the usb chipset that has issues with it, use a 2.5 to 3.5 pata adapter, then connect it directly to the motherboard of a desktop with a IDE cable, take the usb chip out of the equation.



  • or dealextreme.com/details.dx/sku.727 (with no shipping!) :) Oct 12, 2010 at 14:39
  • @ James, wow an inventory clearance! Too bad I already have 2, soon to be outdated due to the death of Pata.
    – Moab
    Oct 12, 2010 at 17:06
  • Received the item in my 12 Oct post, connected to a 965P-DS3 motherboard with Award F11b BIOS, and it worked perfectly. Nov 3, 2010 at 17:43

The reason this drive won't work on your USB adapter is that these USB adapters only support ATA drives. Your drive from a 386 probably uses PIO, or possibly (but unlikely) UltraDMA.

See this resource for more information: http://www.karbosguide.com/books/pcarchitecture/chapter44.htm

Most motherboards support these old drives just fine. I have no idea why these USB controllers don't, but I suspect that there is a good technical reason for it.

  • but evidently not by my old laptop. Still, I'd already solved the problem, but thanks for your thoughts. Nov 4, 2010 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.