I had a Windows 7 system working fine in AHCI mode and decided to change the motherboard to another brand. I created an image of the boot drive. I changed the motherboard which runs in IDE mode by default. Restored the image and Windows 7 boots up fine. i decided then to switch to AHCI mode.

Verified AHCI HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci is set to 0. Changed IDE to AHCI mode in the BIOS. Windows starts but it's stuck at "Starting Windows" for over an hour before I switched off the machine. I booted from the Windows DVD to get into Startup Repair option but it's also stuck in "Starting Windows" screen! I did another try to do the same but without the DVD using F8 to get the boot menu. Same result. So 3 different ways are giving a stuck "Starting Windows". I don't know why AHCI mode is causing Windows not to boot properly.

Any ideas? Is there a way to clean/remove the current AHCI installation from Windows and start a fresh AHCI installation without reinstalling Windows?

  • Just to be clear, did you restore the image while in IDE mode and switched to AHCI only after running Windows? – Velociraptors Oct 12 '10 at 23:01
  • Yes image was restored while in IDE. – Tony_Henrich Oct 13 '10 at 16:49
  • This is also an issue for me... Asus motherboard, Intel storage controller. Windows has issues booting when AHCI is selected. – TGP1994 Nov 3 '13 at 1:13

What are the motherboards in question? If there's a chipset difference, this could be the problem...that registry key just tells Windows that it should load an AHCI driver if you're running in AHCI mode (note that you can change it and continue to boot in IDE indefinitely...) but if there's ALREADY an AHCI driver loaded, but it needs a different one, it may not be smart enough to do that.

You can't get to Startup Recovery...I assume you can't get to Safe Mode?

Can you boot to the disk or recovery in IDE mode?

I can't think of any other fixes that wouldn't involve slaving the drive to another OS and making some offline changes (and I'm unsure of details).

  • The MB is switched from a Gigabyte to Asus. msachi.sys is Microsoft's and I assume it's a generic one which should works on any MB? or does the Windows install find which chipset is used, picks the proper AHCI driver and names it msahci.sys? I can install a driver when Windows is not running using a tool like Erd Commander but is the proper way to modify the registry to point to another ahci driver file? – Tony_Henrich Oct 12 '10 at 20:39
  • It probably should be working with the base Microsoft one...you might be right in that it's doing some magic behind the scenes but I'm not knowledgeable enough to tell you if that's the case, sorry. I'd recommend trying to boot another way (like I mentioned in the original answer) and install the manufacturer's driver. – Shinrai Oct 13 '10 at 14:16

Shinrai is probably on the right track - if the motherboard is fundamentally different, Windows is not generally clever enough to replace incorrect hardware/chipset/feature drivers on the fly. I had this a while back when a server died and we could not get the system to reboot after having changed the motherboard. We tried every trick we could think of but in the end we fitted a new primary disk, installed the server OS onto it, mounted the original C: drive as a secondary unit (D:) and copied what we needed off it.


I'd suggest that you check your BIOS and see if it is the latest version. If it's not, go to the BIOS website and update it.

I had a similar issue and this solved it.


The Chipset and Sata driver for that new motherboard is different than the old one. Download and install the chipset and sata drivers from the motherboard manufacturers website, and any others you need.


  • I did that but none of the ATA/ATAPI controllers in the device manager mention ahci in their drivers detail. – Tony_Henrich Oct 13 '10 at 16:56

I just experienced the exact same issue with my new rig - no motherboard exchanges were performed. What happened was that I installed with the optical drives configured for IDE mode. I switched the mode of the optical drives from IDE to AHCI - and boom, I experience the exact same problem. This may indicate a Windows 7 bug. It's probably time to visit http://connect.microsoft.com.

  • Microsoft does not accept bug reports for Windows 7 via MS Connect. – Michael Dec 11 '10 at 5:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.