I have a slightly weird issue with VirtualBox. My host OS is Windows 7 (64-bit) and guest OS is Ubuntu 10.10(64-bit). When I switch to fullscreen mode in VirtualBox, Ubuntu display resizes to fit my screen size. however, after that the display is not updated. So if I click a menu or something I don't see it appear. but it seems to work in the background.

if I click a menu in fullscreen mode, I don't see anything happen, but if then switch to windowed mode I see the menu already open. I have installed virtuabox guest additions.

if any has a similar issue or has found a solution please let me know thanks.

migrated from stackoverflow.com Oct 13 '10 at 10:21

This question came from our site for professional and enthusiast programmers.

  • Have you had any resolution on this problem? I am suffering from a similar issue with an Ubuntu 10.10 guest running on VirtualBox 4.0.2 on a Windows 7 host – bunn_online Feb 14 '11 at 17:50
  • @bunn_online: Not yet. I thought it might have been a bug with a 64-bit version so now I'm running Win7(64-bit) and Ubunut 10.10 32-bit. still the same issue. I reported it but no fix yet. :( I'm using VirtualBox 4.04. must be win7 64bit issue. – AtharvaI Feb 23 '11 at 14:55
  • @Atharval: Likewise - I have just upgraded to virtualbox 4.0.4, and upgraded the guest additions on my ubuntu 10.10 VM and I still have the problem. – bunn_online Feb 26 '11 at 7:29
  • I'm having the same problem. Could you post a link to the VirtualBox ticket so we can track its progress? – Jacob Mar 6 '11 at 14:19
  • @Jacob: I would but I've lost the link. Sorry – AtharvaI Mar 21 '11 at 19:49

Sounds like a bug. I've had similar display bugs with Ubuntu + VirtualBox as well, but nothing that I could not work around. I would report this to VirtualBox - they are usually pretty good about getting things like this fixed, especially for high-profile OS'es like Ubuntu. Keep in mind that Ubuntu 10.10 is only 3 days old, and of course may have some new "features" that VirtualBox hasn't compensated for yet.


I fought with this one for a several hours (++++). What I found is that for some reason when switching from fullscreen to scaled mode that I lost the menu and status icons, hence lost control. The VM would stretch and it looked like it was stretched but still no menu. I fought this, even looked a vboxmanage for a solution. It was driving me crazy.

I searched and searched and I finally found the answer and here is the solution to getting your menus back. What you need to do is use a shortcut. In the menus all of the functions have corresponding shortcuts, but what if you have no access to the "hostkey". Well the answer is to press the [ctrl] + [->] keys and [F] key. This will toggle your screen mode and recover your menus and thus your access.

It is a simple answer, but a maddening difficult one to find the solution. I thank the person who posted the answer, and unfortunately I didn't remember their screen name, but my thanks goes out to them once again.

I hope this helps, Jim

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.