Bottom Line:

I need to set up one game on my little sister's laptop to run without requiring an admin password/account. Its the only game that seems to insist on it... so far.

Detailed Version:

I set up my 14-year-old sister as a regular user on her Windows 7 Home Premium laptop, and almost everything has been fine - until she found a new game (Flyff) that doesn't seem to want to run without an Admin Password (or being logged in as an Admin).

For what should be obvious reasons, I'm not going to make her an Admin. or give her the Admin password (which she swears she'll only use to run this game... anyone else buying that? Bueller?)

Also, the parents aren't admins on her laptop (they are on their own, but that's another discussion for another day) and I'm not going to set them up as one as I know from past experience that the 3rd time my sister asks them to put in their password, they'll just tell her what it is - at which point I might as well as have just set her up as an admin from the outset.

This is a Win7 Home Premium (64-bit, but I doubt that makes a difference) laptop, so using GPEdit is out.

I also tried an answer provided in a related (but less specific) question. The app has read/write permissions for its folder in Program Files (x86), yet that doesn't seem to make a difference.

I have not yet dug through the registry as mentioned in another answer to the aforementioned question.

Just to be thorough, I have checked the "Run as Admin" option on the shortcut's properties to no avail.

Am I missing something?

Addendum 2010-11-11:

Re-Checked permissions as per Joel's answer, and it didn't make a difference.

Followed Jane T's suggestion (and Aeo's second) and created a "Games" folder outside Program Files, installing the game there - and making sure regular users had all the permissions they would need. No joy.

After the latter of the above two changes, it occurred to me that it may be a UAC issue, so for kicks I turned off UAC - still the damn message.

Last item noted: could it be a result of the publisher not being specified/verified? I've been taking a closer look at the error message and it occurred to me that the missing/unverified publisher info could have been the problem all along... Correct me if I'm wrong, but if that's the case, that means there's nothing I can do short of giving her some sort of Admin privileges (i.e. elevating her account, or giving her the password to a separate Admin account) or giving Mom an Admin account.

  • 1
    Have you tried installing the program outside of the Program Files folder? – Jane T Oct 13 '10 at 17:54
  • 1
    I believe it requires administrator because of Gameguard or the anti-cheat system they use. – qroberts Oct 13 '10 at 17:56
  • Jane T has the most common solution to this issue. I've got a folder, C:/Games/, specifically for troublesome games like this. – Aeo Oct 13 '10 at 18:17
  • @Jane: IIRC it didn't offer the option. But I'll double-check tonight or Saturday. – AnonJr Oct 13 '10 at 20:16
  • @qroberts: I'll see if I can spot a folder for Gameguard and a few other anti-cheat systems I know of. FWIW, Punkbuster works fine with Joint Operations... [ yes, both of my sisters play Joint Ops with the guys from Church every Saturday :) ] – AnonJr Oct 13 '10 at 20:18

This solved the issue for me:

  1. Install the game outside the Program Files directory; e.g. C:\Games\Flyff.
  2. Give Everyone full control permissions on that directory.
  3. Install and run Microsoft Application Compatibility Toolkit.
  4. Create a new fix.
  5. Configure it to Windows XP (Service Pack 2) and Run as Invoker.
  6. Finish and install the fix.

Detailed instructions on this article: Disable UAC for specific programs.


Odds are the game just needs write access to a folder that doesn't by default allow this. The usual culprit is the the program's Program Files folder, but sometimes games also want write access to a folder directly under the C: drive. Log in as admin and set that folder to allow write access for standard security users.

Also, to sidestep the issue I wasn't able to look up the game, as the web site is blocked at work here as a "gambling" site.

  • Finally got a hold of my sister's laptop with some time to work on it. No joy after changing permissions in the program's Program Files folder. Love those work filters... – AnonJr Nov 11 '10 at 15:56

Can't you right-click on the program's executable and set it to run as Administrator?

  • You can, but as I mentioned I have checked the "Run as Admin" option on the shortcut's properties to no avail. It still requires an Admin account or at least an Admin's password. – AnonJr Nov 15 '10 at 20:03

I've had this issue a few times, and I'd created a batch file that had an admin username/password hard coded into it. Terrible security I know, but if it was used in combination with something to run batch files invisibly then maybe she wouldn't poke around into why her game suddenly works.

This problem seems common with F2P games these days, Atlantica used to ask for admin rights (permission to modify the hdd) all the time. I don't play anymore though, so I can't say for sure if they fixed that issue or not since it was basically preventing non-admin users from playing.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.