Sometimes, when changing the resolution on windows, it just changes it and does nothing more. On some computers, it asks "do you want to keep these display settings?" and if you click nothing within 15 seconds it reverts them. What controls whether the dialog appears? How can I disable it?

3 Answers 3


If there's a way to disable the dialog once and for all, I don't know what it is, but I do know how to do it for individual video modes. Prepare for a complicated answer to a simple question.

The thing that determines whether that dialog appears is whether the mode you're switching to has been used on that system before. It therefore stands to reason that convincing Windows that the mode you want to use had been used before would disable the dialog.

So, I did some digging for where this information might be stored, and it seems that, on XP at least, the place is the registry path

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Control Panel\Settings\Video\[key named after your video adapter's device ID]\[key named after your monitor and its GUID]

Under this path, there are keys named in the format "[width]x[height] x [refresh rate]Hz". Under those keys, there are DWORD values for color depths in the format "[depth] bpp", which are set to 1 if that depth has been used at that resolution and refresh rate. So, if you wanted to disable the dialog for 1280x720@60Hz and 32 bit color, you would make a key called "1280x720 x 60Hz" and put a DWORD value in it called "32 bpp" and set it to 1.

Now, you don't say what you need this for, so I don't know how you would want to deploy it, or even how you could, given that GUID in there; if it's not for a large number of installations, I would say this is more trouble than it's worth.

  • 1
    good show sir. upvote. to improve this method for mass deployment you could export HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Control Panel\Settings\Video\ then script the adds for common video modes and import again i think Oct 25, 2010 at 12:42
  • Unfortunately, this key is missing on Windows 10.
    – White hawk
    May 4, 2020 at 14:49

Right Click on your desktop and go to "Properties". Under the Settings Tab, Click Advanced. Under the General tab, there is a Compatibility section. The settings are technically there. What I found works is to set it to "Ask me before applying changes". When the window pops up click the "Do not ask me again" check box.

You shouldn't have that prompt anymore.

Hope that helps.

  • hm i think that only disables that dialog, not the one that pops up after the display settings change
    – Claudiu
    Oct 20, 2010 at 22:35
  • I tired it out on my windows XP machine and was able to switch modes without having the pop up. The trick is that you have to check the "do not ask me again" box in order to prevent the popup. It's a little backwards, but I'm curious if it works on your machine. Oct 22, 2010 at 15:59

I'm not sure, but may it be that this is only asked with analogue connectors like VGA? Because there's no check if the connected device can handle that resolution. DVI/HDMI both have those capability informations.

  • happened in a virtual machine too, but only sometimes
    – Claudiu
    Oct 20, 2010 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.