19

I connect to my server from Terminal in Mac OS X 10.5. When I run Midnight Commander there I cannot use function keys like F10 to close MC even I cannot use mouse to control MC. Any idea why function keys don't work ?

migrated from stackoverflow.com Oct 15 '10 at 18:44

This question came from our site for professional and enthusiast programmers.

  • migrate to serverfault.com? – KevinDTimm Oct 15 '10 at 18:23
  • Have you tried Function-F10? By default I believe the F-keys are mapped to the functions. – 8BitsOfGeek Oct 15 '10 at 18:55
  • Please accept an answer if it satisfies your question, otherwise please follow up with additional requirements/comments. – Daniel Beck Oct 22 '10 at 20:51
48

Don't know why the Fx keys don't work, but you can press Esc, then 0 to simulate F10. Also works with 1-9 for F1-F9.

  • 2
    That's solve the same problem even though I'm not in OsX. – JuanZe Sep 27 '11 at 13:31
8

Function keys are used to control both software and hardware functions as well as Dashboard and Expose in Mac OS X. If you have a Macbook Pro, F1 and F2 control screen lighting, F10 mutes the speakers, etc.

Check the Keyboard preference pane in System Preferences.app:

  1. Is the checkbox "Use all F1, F2, etc. keys as standard function keys" on the "Keyboard tab" checked? If it's not, you need to press Fn+F10 for Mac OS to register a F10 key press. Otherwise, you're just toggling mute speakers (or whatever you have on F10).

  2. Check the second tab, "Keyboard Shortcuts", especially "Dashboard & Dock", and "Exposé & Spaces", if F10 is used for one of these functions. If it is, the key press is intercepted before Terminal receives it.

This answer was written for Mac OS X 10.6, I don't know if those dialogs were changed. If step 2 above does not work, check the Dashboard/Expose/Spaces preference pane in System Preferences, the same settings should be available there.

2

To send F1-F12 keys to an ncurses program running in Terminal.app press fn+command+F1…F12. This works for me on a MacBook Air with OS X 10.9.

0

This problem occurs because of ansi terminfo.
You can change declaration to xterm in Terminal Preferences Advanced Tab and fn keys will work.

-1
  • Go to 'System Preferences...' select 'Expose & Spaces' Preference Pane.
  • Click on the Expos Tab.
  • Change the All Windows Setting to for instance F11
  • Change Application Windows Setting to for instance F12
  • Change Show Desktop Setting to for instance F13
  • Close System Preferences App

And your Terminal is able to respond to the Function Keys correctly and you're able to quit Midnight Commander.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.