2

I'm having an issue on a Macbook Pro running Mac OS X 10.5, I'm unable to visit certain websites such as: "themarchesa.com"

On other computers in the same LAN network connected over wifi I'm able to see those sites fine and run a traceroute succesfully.

When I run a traceroute from the terminal it doesn't even appear to go out to the wireless router gateway:

angela-dions-macbook-pro:~ Angie$ traceroute themarchesa.com
traceroute to themarchesa.com (64.202.189.170), 64 hops max, 40 byte packets
traceroute: sendto: No route to host
 1 traceroute: wrote themarchesa.com 40 chars, ret=-1
 *traceroute: sendto: No route to host
traceroute: wrote themarchesa.com 40 chars, ret=-1

When I run the same command on google.com it looks different:

angela-dions-macbook-pro:~ Angie$ traceroute google.com
traceroute: Warning: google.com has multiple addresses; using 74.125.227.18
traceroute to google.com (74.125.227.18), 64 hops max, 40 byte packets
 1  192.168.1.1 (192.168.1.1)  3.768 ms  6.499 ms  6.716 ms
 2  * * *
 3  gig3-11.austtxk-rtr2.austin.rr.com (66.68.1.253)  15.161 ms  24.131 ms  16.291 ms
 4  Gi0-2-1-1.austtxrdcsc-rtr2.austin.rr.com (24.27.12.174)  18.678 ms  26.495 ms  16.064 ms
 5  gig6-3-0.dllatxl3-rtr1.texas.rr.com (72.179.205.76)  15.589 ms  18.537 ms  18.427 ms
 6  ae-4-0.cr0.dfw10.tbone.rr.com (66.109.6.88)  16.404 ms  24.141 ms  27.108 ms
 7  ae-1-0.pr0.dfw10.tbone.rr.com (66.109.6.179)  25.488 ms  19.721 ms  20.257 ms
 8  74.125.48.65 (74.125.48.65)  20.165 ms  22.483 ms  21.444 ms
 9  72.14.233.65 (72.14.233.65)  20.186 ms  25.394 ms  20.003 ms
10  216.239.47.54 (216.239.47.54)  24.236 ms  37.011 ms  38.239 ms
11  74.125.227.18 (74.125.227.18)  27.468 ms  27.292 ms  20.032 ms

EDIT: Here's the output of route get on the IP address:

angela-dions-macbook-pro:~ Angie$ route get 64.202.189.170
   route to: pwfwd-v01.prod.mesa1.secureserver.net
destination: default
       mask: default
    gateway: 192.168.1.1
  interface: en1
      flags: <UP,GATEWAY,DONE,STATIC,PRCLONING>
 recvpipe  sendpipe  ssthresh  rtt,msec    rttvar  hopcount      mtu     expire
       0         0         0         0         0         0      1500         0 

Also here's my routing table information if that helps out (what else could cause this to happen). I'm able to run traceroute and visit the website on other machines on the same LAN (connected to the same router over wifi).

angela-dions-macbook-pro:~ Angie$ netstat -rn
Routing tables

Internet:
Destination        Gateway            Flags    Refs      Use  Netif Expire
default            192.168.1.1        UGSc       30        0    en1
127                127.0.0.1          UCS         0        0    lo0
127.0.0.1          127.0.0.1          UH          1    19326    lo0
169.254            link#5             UCS         0        0    en1
192.168.1          link#5             UCS         4        0    en1
192.168.1.1        0:18:f8:b7:45:7c   UHLW       26      112    en1    955
192.168.1.107      7c:6d:62:d2:43:99  UHLW        0        0    en1   1198
192.168.1.111      127.0.0.1          UHS         0        0    lo0
192.168.1.255      link#5             UHLWb       3       18    en1

Internet6:
Destination                             Gateway                         Flags      Netif Expire
::1                                     link#1                          UHL         lo0
fe80::%lo0/64                           fe80::1%lo0                     Uc          lo0
fe80::1%lo0                             link#1                          UHL         lo0
fe80::%en1/64                           link#5                          UC          en1
fe80::21f:5bff:fec7:aed7%en1            0:1f:5b:c7:ae:d7                UHLW        en1
fe80::223:6cff:fe88:f0bd%en1            0:23:6c:88:f0:bd                UHL         lo0
ff01::/32                               ::1                             U           lo0
ff02::/32                               fe80::1%lo0                     UC          lo0
ff02::/32                               link#5                          UC          en1

I'm not sure what else I can do to debug this issue, what should I use to help debug and fix this issue?

There were some people that ran into a similiar issue and used some cache cleaning tools (but it seemed like the problem kept popping up, feels almost like a virus?):

3
  • netstat -rn will show your routing table. We should compare that with your traceroute results. – benc Oct 16 '10 at 2:19
  • 1
    The output of route get 64.202.189.170 might also be informative. – Gordon Davisson Oct 16 '10 at 3:05
  • thanks for the extra diagnostic tools, I edited the question to include both netstat -rn and route get. – angelamia Oct 16 '10 at 6:12
1

The issue turned out to be Peer Guardian, I had to disable the filters and then I was able to hit those websites.

1

Transmission has built-in block list support, which means you don't need to use Peer Guardian, avoiding such issues.

0
sudo route flush

try it. I face similar problem and solved using this command. Some hosts were disappeared and couldn't be accessed.

2
  • This answer would be better if it explained why that command works. An example of what the routing table looks before and after to illustrate it would also help. – kasperd Nov 1 '18 at 13:53
  • It happens like that. When I use vpn that uses same ip zone as my local LAN then after it disconnects with some error then my vpn client can't flush the route so it panics or something happens. If I disconnects my VPN connection using disconnect command it's fine. I'm not a network guy. I just thought about it some cache or some panic related routing table cache is making this problem... So I flushed it and it works..... I think network experts can explain it better... :) . Hope you got my idea. – Batmunkh Moltov Feb 20 '19 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.