I am running a Ubuntu inside VMware player and it was working fine. But then I updated the ubuntu to latest version of it and from then it is not able to connect to the host i.e. Windows 7. Thus it is also not able to connect to internet. Can anyone tell how do I restore the connection with host. FYI - I have VMware Player network adapter configured in Bridged mode.

  • Strictly speaking I don't think this is a Stackoverflow kind of question. – Pointy Oct 16 '10 at 0:39

Once you select the NAT, from the guest Ubuntu (12.04 for my case), choose the connection as "DHCP (Automatic)" NOT "DHCP (Automatic) addresses only". This worked for me. I am running Vista 32 Host and Ubuntu 12.04 guest.

| improve this answer | |

A bridged connection isn't necessary for a simple connection to the internet or the host but I'll assume that you choose a bridged connection because you need the guest to be a part of the same physical network that the host is. I haven't seen this particular problem but I can think of a few things to try.

  1. Check the TCP/IP settings in both the host and the guest. They should have IP addresses within the same subnet, the same dns and default gateway.
  2. Remove the virtual network adapter, shutdown the vm and add it again. If you have more than one network adapter, it's hard to tell which one it will "bridge" with.
  3. I was having trouble with shared folders and the solution turned out to be to reinstall VMware tools. If libraries were updated then you may have broken VMware tools compatiblity with Ubuntu. Luckily the automated perl script that installs it can also build new binaries!
| improve this answer | |

From my personal experience, check your Anti-Virus Firewall on your host (Windows 7) as well. AVG Internet Security for instance has a "Enable Virtual Machine Bridged networking", which if not enabled, does not allow your guest VM to access your host's network.

enter image description here

| improve this answer | |

This worked for me.

When executed "ifconfig -a", the output did show an active virtual NIC, but the system could not connect to internet because it didn't have an IP address associated to the NIC (I had given a Bridged network to the guest Ubuntu).

To get it working, edit the file: /etc/network/interfaces

Add these lines:

# The primary network interface
auto [vNIC name as appeared on "ifconfig -a" output]
iface [vNIC name] inet dhcp

(remove the angular brackets)
Don't change anything of the loopback interface if you see one.

Save the file and reboot the system. That should do it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy