26

when i enter terminals commands etc and hit TAB (file name completion) the whole terminal window flashes rapidly (if there is no unique filename for example). This is not good since for some people this can trigger a seizure, and for me it causes really bad headaches. Is there a way we can disable this flashing?

migrated from stackoverflow.com Oct 19 '10 at 19:53

This question came from our site for professional and enthusiast programmers.

  • Probably more suited to superuser.com – dtlussier Oct 19 '10 at 19:18
33

Uncheck the 'visual bell' box in the preferences for your terminal style.

  • 2
    If that's already off, make sure you have disabled System Preferences > Universal Access > Hearing > Flash the screen when an alert sound occurs. – alex Sep 18 '12 at 0:18
9

This is probably not the right place to ask this question. But there is a setting for that: Settings/Advanced/Visual bell

5

Step (1) - Disable Visual Bell

Terminal > Preferences > Profiles > Advanced > Bell

Uncheck the "Visual Bell"

Step (2) - When Audible Bell is still enabled and screen continues to flash

System Preferences > Accessibilty > Audio

Uncheck the "Flash screen when alert sound occurs"

1

If anyone is using iTerm2 and having this problem, try going into Preferences->Profiles->Terminal and check "Silence Bell".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy