23

I´m using Windows 7 x64. I can see the .jpg, .gif, etc. preview thumbnails but if .PNG, I only see the generic image, and not the image preview like in the other formats.

What can I do to fix this?

31

I had this same problem and was able to fix it with two steps, although, I'm uncertain I actually needed to do the first step:

  1. In Windows Explorer, I right clicked on a .PNG file, went to Open With, selected Choose Default Program... and chose Windows Photo Viewer as the default program to open .PNG files. This changed all my .PNG thumbnails to an icon of flowers. (I don't think this was required, but including what I did for completeness.)

    (If the menu is not visible press Alt)

  2. In Windows Explorer, I clicked Tools, Folder options, went to the View tab, expanded Files and Folders and removed the check mark from Always show icons, never thumbnails. (I think this is all I had to do to make it work, but have not verified that.)

| improve this answer | |
  • 7
    #2 sorted it for me! What a weird default... – Jamie Brown Jul 21 '14 at 12:43
  • Did not work. Thank you for trying. – Obi Wan Sep 11 '15 at 15:14
  • What fixed it for me was turning the option in point 2 on then off again. – Chris H Sep 1 '16 at 8:36
  • Preview did not work for me if the file was inside a .zip. I had to extract the file from the .zip, then Preview worked. (Windows 7) – Mike Taverne Jan 19 '17 at 22:29
  • Worked for me while on Windows 10 – Ferdinando Santacroce Jun 22 '18 at 16:10
2

It could potentially be an issue with the icon cache on the computer.

Perhaps take a look at this issue here I don't know if its the same issue but it seems to be a few easy steps that could potentially resolve your problem

Rebuilding the Icon Cache Database

  1. Close all folder windows that are currently open.
  2. Launch Task Manager using the CTRL+SHIFT+ESC key sequence, or by running taskmgr.exe.
  3. In the Process tab, right-click on the Explorer.exe process and select End Process.
  4. Click the End process button when asked for confirmation.
  5. From the File menu of Task Manager, select New Task (Run…)
  6. Type CMD.EXE, and click OK
  7. In the Command Prompt window, type the commands one by one and press ENTER after each command: CD /d %userprofile%\AppData\Local DEL IconCache.db /a EXIT
  8. In Task Manager, click File, select New Task (Run…)
  9. Type EXPLORER.EXE, and click OK.
| improve this answer | |
  • We appreciate your effort but this did not work. – Obi Wan Sep 11 '15 at 15:18
  • It did work for me on Windows 8.1! Thanks! – Nikos Jan 14 '18 at 15:42
1

By following the next two steps, I was able to have the .PNG thumbnails restored. I am not sure whether both of them are necessary to fix the problem, though.

1. For me, the problem was caused by installing another piece of software (SageThumbs, in my case), which allowed me to display thumbnails for graphic file extensions that Windows 7 doesn't support natively. By turning off the function to generate thumbnails inside this third-party software, the cause of the problem was - presumably - gone.

2. Get rid of the current set of cached thumbnails (in '%userprofile%\AppData\Local\Microsoft\Windows\Explorer'). Trying to delete them manually didn't work, nor did selecting the option in CCleaner ('0 bytes removed' message). I was however able to delete the Windows 7 thumbnail cache by going to Start/Accessories/System Tools/Disk Cleanup, and selecting the option in the options list.

| improve this answer | |
0

I had to turn 'Always show icons, never thumbnails' on (checked) and then back off (un-checked). Thanks to Chris H Sep 1 '16 at 8:36 for the idea.

Windows 10

  • In Windows Explorer
  • I clicked View (in the ribbon)
  • Options
  • Went to the View tab
  • Under Files and Folders
  • Checked 'Always show icons, never thumbnails'
  • Clicked Ok
  • Went Back into Options (View Tab)
  • Un-checked 'Always show icons, never thumbnails'

Note - prior to this I did change the default association for PNG to be Photo Viewer. Not sure if this step was required.

| improve this answer | |
0

The reason my png wasn't showing was that I was looking at the file inside of an archive(.zip). I simply needed to extract the png file and then the thumbnail was visible.

The icon view also needed to be set to medium icons or larger.

| improve this answer | |
  • What makes you think that the questioner is looking at the file in a .zip archive? – Blackwood Dec 20 '17 at 1:22
  • @Blackwood Regardless of whether he was, this was the solution for me, and it's reasonable to assume that it will be the solution for others that are searching as well. Considering that OP posted this question in 2010, I hope he's found his answer. – FragmentalStew Dec 24 '17 at 20:19
0

This is caused by having a program installed, such as Adobe Photoshop, that takes away the "default program" from Windows Photo Viewer. The simplest way to restore thumbnail for png right here: - Just Right-Click on your png file -> Open with -> Choose another app -> Choose app Photos & stick to Always use this app to open .png files -> Restart your machine.

| improve this answer | |
  • Welcome to Super User. This answer essential duplicates content in this and this answer. Perhaps you intend your answer to apply to an OS other than Windows 7? If so, please edit it to say so. Thanks for contributing. – I say Reinstate Monica Sep 29 '18 at 18:55
0

Had this problem too (Jan 2020) and nothing above worked but then it dawned on me that the PNG files I was trying to work with and weren't previewing were still on my phone...which was connected to a USB port on my computer. So when I cut and pasted them off the phone and into 'Pictures' on my PC, Windows Explorer previewed them straight away.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.