10

I have a small(?) issue program. A friend of mine has a computer with the following specs:

  • Creative XtremeMusic soundcard (latest x-fi drivers, the complete package)
  • USB Midimate 2 (usb midi interface)
  • Yamaha CS1x keyboard with midi outs (connects to computer with MidiMate 2)
  • Program called Ableton Live 8.1 to record midi and playback midi

My problem is the following.

Creative delivers it's own ASIO drivers, but those aren't as good as the ASIO4ALL drivers. That's why ASIO4ALL is recommended. (the sound and the latency is much better)

When installing the ASIO4ALL drivers, you will get a option in Ableton to use them. The only problem is that MS GS WAVETABLE synth? occupies the output and that's the reason why you can't hear any sounds through the speakers. When enabling the Creative ASIO driver, the sounds are back.

GS MS Wavetable occuping synth

p.s. this is a pic from the internet, not one from the system, it's a other soundcard, but the same error message.

In forums there are a few solutions which worked for a few people, but also not working for many others.

Here is a small list of (might work) solutions (i tried all those)

1:Right click the volume icon in your system tray
2: click playback devices
3:right click speakers
4: click properties
5: click advanced
6: uncheck "allow applications to take eclusive control of this device"
7: uncheck "give exclusive mode applications priority"
8: open FL Studio 8(or any program for music that supports ASIO4ALL or ASSIO4ALL2)
9: click options
10: click audio settings
11: change device to ASIO4ALL or ASIO4ALL2
12: Click "Show asio panel"
13: click advanced
14: check "always resample 44.1kHz <-> 48 KHz"
15: MAKE MUSIC! :D

The only thing I couldn't try yet was the one I found writing this question.

  • Control Panel -> Sounds/Audio -> Audio tab -> volume button in "Midi playback"--MUTE SW SYNTH

The solution above sounds logical, because I didn't connect the midi synthesizer with the midi port (gameport) of the X-fi soundcard but with a USB interface of the midimate 2

Could this solve it? or does anyone have other options?

Fix: Just indeed disable de midi synth as described above, and turn off systemsounds.

  • I'm guessing that Ableton Live itself has mapped a MIDI output to the synth. Disable it, or configure the synth to use a different sound output. – Brad Apr 21 '14 at 20:40
1

I fixed a similar (possibly the same) issue by disabling all system sounds in the "change system sounds" settings dialogue - which is a good idea for anyone doing music production on their computer. You can get there by right clicking the sound icon in the system tray, choosing playback devices, then clicking on the "sounds" tab on the top. Under "sound schemes", select "no sounds." This prevents the windows os from accessing the default midi definition file (MS GS WAVETABLE SYNTH), which seems to be your issue.

If that doesn't work, you could see if your driver has a settings dialogue that allows you to disable the midi features of the drivers.

Does your midi controller support it's own midi definitions? You are likely to have more success if you use something besides Microsoft's very generic sounding midi table. If I'm not using my midi keyboard, I typically run my midi through a plugin like SFZ so I can control the midi output format. You can download free midi banks and soundfonts on many different websites.

0

I got around the wavetable problem by downloading the demo for FLstudio 12 which contains a driver called FLstudio ASIO which now shows up in most, but not all ASIO using apps and doesn't have the Wavetable problem. I think you can even uninstall FLstudio 12 and the FLstudio ASIO driver will still be available.

-1

I believe you cannot mix a DSP based digital mixer with an Analog Windows mixer. The Windows mixer which includes your Vinyl Audio and Midi wavetable cannot mix with USB headphones nor X-FI sound card. Both are Digital audio sources.

ASIO4ALL allows one to create connections in analog sound from port to port that are analog only.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.