I just found my ASUS Crosshair II Formula was broken. I have requested an RMA and I'll have to wait more than one month and a half to get a replacement. Meanwhile, I found that my old ASUS Crosshair was working so I replaced the motherboard until I get the new one.

Now Windows 7 x64 doesn't boot. openSUSE 11.3 x64 does. Windows actually reboots after a flash-blue-screen even if I try to load safe mode.

I already know I can format, but I don't want for now.

The problem is that I have 5 HDDs and Crosshair II was in AHCI mode to make OS detect all 6 SATA ports. Crosshair classic has 6 SATA ports, but they are regular SATA controllers. When I upgraded Crosshair to Crosshair II with Vista, I had the same exact problem of Windows rebooting when SATA ports were set to AHCI (when set to IDE I could see only 4, as documented on the manual).

I'm sure that now, during the downgrade, the same kind of problem is occurring. When I had Vista I was able to install mobo drivers in IDE mode then run system restore in AHCI mode and let it do something about it.

Do you have any ideas? I tried disabling "Silicon SATAII controller" on BIOS but didn't help (and it still detects 5 HDDs)

Update: this is what I tried with Vista, just to be complete - http://www.avforums.com/forums/windows-7/944905-windows-7-ahci.html

  • Do a repair install, perhaps ? – Sathyajith Bhat Oct 21 '10 at 20:11
  • Does it keep my software intact? I just tried to remove GRUB (as you could guess, I'm in dual boot) and I'm currently running the system repair, lessee if it works – usr-local-ΕΨΗΕΛΩΝ Oct 21 '10 at 20:13
  • @djechelon - It just rebuilds the bootloader and replaces some system files. You should be fine. (You'll have to reconstruct your dual-boot though.) – Shinrai Oct 21 '10 at 20:16
  • Seems Seven's DVD is able to do only fresh install (=formatting). I have a clue. If I can edit my Windows's registry from recovery console or elsewhere, I might set the proper AHCI registry key as suggested in the article linked in my post. Tried regedit from recovery console but seems that fixed don't get applied (next reboot, same values). Any ideas? – usr-local-ΕΨΗΕΛΩΝ Oct 21 '10 at 20:51
  • You can only do a repair install from within Windows 7, you cannot do a repair install at boot or in Safe Mode. You must be logged into Windows 7 in a administrator account to be able to do a repair install.....sevenforums.com/tutorials/3413-repair-install.html – Moab Oct 21 '10 at 21:48

Finally found the solution by myself.

AHCI Vs IDE tutorials helped me a lot, particularly this one: http://www.vistax64.com/drivers/155040-disabling-ahci-bsod.html

Those having my same problem (switching from AHCI to IDE without being able to boot in AHCI) must do the following steps:

  • Boot into Recovery mode, and open console,
  • Load regedit.exe
  • Load a registry hive from c:\windows\system32\config\system into a key (it's needed because what you see in regedit is the recovery mode's registry, and is volatile)
  • Go to your Windows's HLKM\System\ControlSet001\Services (the hive you imported)
  • If you have Intel CPU, enable iaStorV service (read later)
  • If you have AMD CPU, enable all IDE-related services that start with amd

To enable a driver during boot: on its key, find the Start value and set it to 0 (it should be set to 3 when you see it).

However, just to be sure, I enabled several more drivers, and it worked. Now I can logon to Windows. Also +1 to edit the windows registry file, system.dat

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.