Between two Windows 7 Ultimate computers. Worked fine up until about an hour ago. File sharing, web browsing works ok too.

Remote Desktop Connection

An authentication error has occurred. The requested security package does not exist

Remote Computer: Computer-Name


I found http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/7698b90a-0708-4aa2-a33b-9734de14319c and discovered that the broken computer was missing those values, but after I restored them, it was still broken.




HKLM\system\currentcontrolset\control\lsa\security packages

It should have these values: kerberos msv1_0 schannel wdigest tspkg pku2u

The tspkg and pku2u values were missing.

  • I mentioned this in my question. All of the computers involved have had Windows reinstalled since I asked so I couldn't try any new answers anyway though.
    – Fowl
    Jan 18 '12 at 23:54
  • The order of these values is very important: I was trying to prevent this (ampliasecurity.com/research/wcefaq.html#digestauth) from working, and while it did, it also hosed RDP to 2008 boxes; when I re-added wdigest, I had it last and after rebooting, still no dice.
    – gravyface
    Jun 6 '12 at 15:12
  • I'm going to assume this would have worked.
    – Fowl
    Jun 18 '12 at 1:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.