I had done some tweaks in service settings (Disabled some as I thought it is not needed). Now, I am not getting the option to safely remove mass storage device when I click the icon on the system tray. I tried enabling some of the services, but it didn't help. Moreover I'm not very sure if this anomaly is because of my changes in services.

Any idea how to make those 'safely remove' options appear when I click the USB icon on the tray. Right now nothing is happening when I click.


6 Answers 6


I have stopped depending on that tray icon.
The RemoveDrive tool is very good and
manages to Safely Remove the removable drives many times after that icon declares failure.

Suggest reading up the notes on the RemoveDrive page
(and several other pages from the same place)
to build your confidence on that tool.
Then, use it if you like it.

I typically keep a shortcut as shown here on the desktop as an immediate fall-back.

C:\some\path\RemoveDrive.exe U:\ -i -b

You can do that from the command line if your drive letter keeps changing.

  • thanks mate. It really works. The interesting thing is that even the windows default click option appeared after once unmounting with the tool. Can't explain this strange phenomenon! Commented Aug 9, 2009 at 18:21
  • You need adminstrative rights to run that I believe. Side question what if this still doesn't work and I get failed is there a way to force quit the applications using the drive?
    – William
    Commented Jan 30, 2017 at 15:10
  • @William, i think you are right about the admin rights part. And, for your new question IMO you should raise a separate one here if you don't find it already addressed (with a reference to this question if you think that is useful). You will have more mileage that way.
    – nik
    Commented Jan 31, 2017 at 6:11

Your device might be optimized for quick removal. That is, the write cache may be disabled. If so there is no need to turn the device off before removal.

In "My Computer" right click on the device and get "properties". Click the "Hardware" tab. Highlight the device (again) and click the "properties" button.


Have you tried this procedure?

Right-click the Start button, select Properties, Taskbar tab,
Customize... button. Find the Safely Remove Hardware icon and select
either Hide when inactive, Always show, but not Always hide.
  • 1
    Its not the icon that isn't showing, it's the "safely remove" option when he right-clicks it
    – user1931
    Commented Aug 9, 2009 at 17:36
  • that is already set to "show icon always" Commented Aug 9, 2009 at 17:37
  • i can see the icon, but not rt click options Commented Aug 9, 2009 at 17:39
  • What does it do when you left click on it?
    – Axxmasterr
    Commented Aug 9, 2009 at 17:40
  • nothing is showing up even on left click. Now my only option is to hibernate the system to remove ext hard disk safely! Commented Aug 9, 2009 at 17:42

Try this:

Check if you have installed libusb-win32, possibly this is the problem, uninstall it and tell us.

Ps: this program may not appear in Add or Remove Programs, so look in the Start menu, if not find it, do not discard yet, in "run" put "install-filer -u" without quotes (You must run as administrator), if execute, ok, if windows can not find the related application probably is not installed, in which case i don't know what is causing the problem.


I had this problem on a Windows XP Pro. SP3 machine. It was fixed by restoring the system to the state a few days back in System Restore.

  • Seems rather extreme no?
    – soandos
    Commented Oct 21, 2012 at 1:04

Reached here after having same problem. RemoveDrive utility didn't work even in elevated command prompt on Windows 10

What worked for me is Goto Disk Management diskmgmt.msc in Run or from Control Panel > Administrative Tools > Computer Management (Disk Management will be under Storage)

Make the problem disk offline then remove disk from Safely Remove Hardware and Eject Media icon in taskbar. Switching it back online and then removing device also works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .