I just got myself a brand new Toshiba Satellite L670-187 17,3" notebook. On first boot it worked fine and I could just connect to my wireless network immediately. However, when the notebook has been turned off for several hours, my WLAN adapter suddenly is no longer detected (nor is it visible in Device Management). Only my LAN adapter is detected and operational.

When I click "Detect new hardware" in Device Management, it detects the WLAN adapter but it won't connect to any wireless networks, instead it just displays the wireless signal bars with a red X in my systray. If I reboot, the wireless network is automatically detected and connected to.

When I power of the laptop and reboot after a few hours, suddenly the WLAN adapter has gone missing again. I turned off the option that Windows is allowed to power off the device to save power, have reinstalled Windows, reinstalled all drivers and tried all available drivers for the WLAN adapter I could find. As far as I know, it works fine under Ubuntu so I figure it's a Windows issue. Furthermore, the issue persists when using a not-OEM Windows disk to reinstall.

The network switch is turned to ON and FN + F8 doesn't do anything.

Below are the specs:

Type : Intel® Core™ i3-350M Processor  
Speed : 2.26 GHz  
Front Side Bus : 1.066 MHz  
3rd level cache : 3 MB  

Size : 4,096 (2,048 + 2,048) MB
Max expansion : 8,192 MB
Technology : DDR3 RAM (1,066 MHz)  

Genuine Windows® 7 Home Premium 64-bit (pre-installed, Toshiba-HDD recovery)

Wireless network adapter:  
Realtek RTL8191SE Wireless LAN 802.11n PCI-E NIC 802.11b/g/n

Any ideas anyone?


If I update the driver automatically with Windows, the adapter is not detected anymore at all until I reinstall the original driver. I have already performed a BIOS update without success.


Three requests for information:

  1. Are you using the Realtek driver from 05/20/10 ?
  2. If you try an external usb wireless NIC, do you have the same problem?
  3. I cannot manage to find your exact notebook model on Toshiba Support site. Could you please supply a link.
|improve this answer|||||
  • No, I'm using the 04/27/10 driver, it's the latest driver available for my model, which is a special dutch model, the dutch model page is found here I haven't tried an external adapter yet. – BloodPhilia Oct 31 '10 at 19:50
  • I can see in Toshiba Europe a driver from July 2010 : aps2.toshiba-tro.de/wlan/?page=downloads. It is Realtek- and OS-specific, not model-specific. – harrymc Oct 31 '10 at 20:50
  • Installing this permanently "hides" my adapter. I had to reboot into safe mode to remove the driver and put back the old one. Any other suggestions? I'm thinking of just calling Toshiba and let them fix it... It shows more flaws and I don't like that on a 2 weeks old laptop... – BloodPhilia Nov 2 '10 at 13:38
  • Yes, I believe you should call Toshiba in any case. But I'm still curious about using another NIC, since that test will firmly point the finger at hardware or software, so you might have more info with which to attack Toshiba Support. – harrymc Nov 2 '10 at 13:44
  • I've tried using a USB connected NIC and it works fine... But I'm having other hardware issues as well (with my keyboard for example) and I think something hardware-like inside that black box might be conflicting. – BloodPhilia Nov 3 '10 at 23:12

If you let it sit for a long time, it might be cooling and contracting. After its been booted up for a few, it might expand just enough to make the connection. Have you cracked open the computer, and reseated the wireless card? Its often sitting in a socket, just like RAM but smaller. You might want to re-seat the chip.

Also, stretching here, but do you have to reset the time when you leave it off for a long time? it might have a bad CMOS battery.

|improve this answer|||||
  • The wireless card is connected properly and no, I do not have to reset the time... As mentioned, it works perfectly fine when using Ubuntu so I figure this is a Windows issue. – BloodPhilia Oct 25 '10 at 15:16

I also experienced the same. After 2 weeks of struggle I found out that It's like the wireless lan card is keep on expiring. Usually you can see the wlan at program at features but its not working at all. Remove and reinstall it. You should shut down and turn off the switch properly to take effect the reinstallation ( dont use restart) Once it (wlan) appears at Device Manager, you must disable the "wifi miniport adapter" which is included ( window 7) and this one makes your pc wifi signal keep on disappearing....Turn "enable" also the adhoc support 802.11 at advance setting. You must turn off also in power management the "allow the computer to turn off this device"entry.

Its all in the device manager that you need to study further. Just try the above things and you can connect again.

Once you done this your pc can connect the whole day but when you turn if off sometimes you will experience the same again but I suggest to do the method that I tell you.

Now I'm searching how to maintain the signal permanently even if you turn off the pc thousand times and I dont need to reinstall that wlan.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.