My Windows XP workstation at the office had several old versions of the Java JDK and JRE installed on it. I decided to install the newest Java JDK and uninstall the older JDKs and JREs. This resulted in some big problems!

First of all, the JDK won't work. Trying to do something as simple as starting the Eclipse IDE just fails. Typing java -version at a command prompt doesn't work either. It seems to be looking for one of the removed JDK installs and the registry is littered with references to the now removed JDK.

So my next move was to uninstall ALL of the Java JDKs and JREs on the machine and start from scratch. Unfortunately, one of the JRE installations appears in the Windows XP "Add or Remove Programs" list, but it is actually already gone from the machine. References to that JRE also exist in a few places in the registry.

So now I used the following utility to try and clean the remnants of Java from my workstation:
JavaRa (1.16)

The tools did find and remove some crap that was left over from the uninstalled JDKs/JREs, but it did not solve the problem.

So this is where I am now:

Trying to install a Java JRE on the machine using the standalone installation downloaded from Sun (or Oracle now I guess).

alt text

alt text

alt text

The installer starts up normally, but then fails after only a second on the progress bar splash screen and then shows this fail message:

alt text

No installer log is created (java_install.log file does not exist), so I don't even have any information to use for diagnosing this problem. It does create the jusched.log file, but that seems to contain nothing useful.

I am totally stumped and I'm kind of screwed if I can't get Java to run on my development workstation. Anyone know what's going on here?

  • 1
    From the sounds of it, you may have some invalid registry entries. Have you tried cleaning it up? CCleaner has a utility built in, or there are a few others out there which might help you.
    – JustXanny
    Oct 25, 2010 at 13:42
  • in my case, an app like ccleaner create the issue when it deleted all uninstall info in computer, so when uninstalling jre 6u20 it always call an windows installer dialog searching for .msi file... and i tried to used the same app to clear registry, but java phantom resides in my notebook regardless of all possible registry and files exorcism methods are applied.... :'(
    – kokbira
    Apr 13, 2012 at 18:57

2 Answers 2


I had to do the same as Jim, no uninstallers worked. For reference, I deleted the "JavaSoft" registry folder, found in HKEY_LOCAL_MACHINE/SOFTWARE, and was able to reinstall perfectly fine.


I tried CCleaner on the registry, but it didn't solve the problem. I was feeling pretty desperate at that point and decided to search the registry with regedt32 for instances of "jdk1.6.0" and delete everything that was obviously garbage. Any registry references to JDK/JRE instances that I knew no longer existed got deleted. Usually this meant deleting the whole key, but there were a few keys where I just had to delete an individual value/data pair. I rebooted after I was done performing meatball surgery on my poor defenceless registry.

DISCLAIMER: I don't recommend that anyone start messing with random keys in their registry as the primary way to solve a problem! This was my last resort before considering the option of re-imaging my workstation and re-installing EVERYTHING.

Having said that, this approach did solve my problem. I was able to install the JRE and then things like Eclipse started working normally once again. I next installed a JDK of the same version without incident.

  • mmm... i deleted all occurrences of "6u20" and "javasoft", and some "java" occurrences, and it functioned - i don't know if by the best way, but i could install 6u30 normally.
    – kokbira
    Apr 13, 2012 at 19:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .