I have a OCZ Vertex 2 256GB flash drive I bought some time ago. I'd like to experiment with Linux on this drive, and I'd like to wipe it factory-clean. Intel provides an "ssd-toolbox" utility which performs a low level format and restores the drive to factory performance, but I cannot seem to find a similar tool for my Vertex 2.

How does one perform a low level block erase on a Sandforce drive?

PS: The drive is in a Dell Latitude E6500. I tried multiple times to use tools which claimed to issue the SECURITY_ERASE ATA command. The free secure erase tool from the Center for Magnetic Research will not start (my guess is that DOS doesn't like the machine with 4GB of RAM), and when I tried to use a linux livecd and hdparm, it reported that my drive was "frozen", and I was unable to find anything in the BIOS to stop it from being frozen.

2 Answers 2


Under unixoid systems you can do it with "hdparm". You need to get "root" first, then do the following. This is assuming that the drive you want to low-level format is "/dev/sda" and that you have "hdparm" installed.

hdparm -I /dev/sda

The parameter is a capital "i", not a lowercase "l", just in case the font is ambiguous. If the drive shows "frozen" you must first "un-freeze" it. What you need to do to "un-freeze" it depends on the device. Most devices will "un-freeze" if you put the system to "suspend to RAM" mode, then wake it up again. If the device shows "not frozen", you can proceed.

hdparm --user-master u --security-set-pass llformat /dev/sda

Then show the device info again with the capital "i" as parameter.

hdparm -I /dev/sda

It should now display "enabled" under "Security:". This is quite a critical step. The device is now secured. If you power it down, it will lock and might become inaccessible. When you perform the low-level format NOW, security will be disabled again and you can continue using the device.

hdparm --user-master u --security-erase llformat /dev/sda

The device should now be physically wiped.

hdparm -I /dev/sda

Once more with the capital "i". Confirm that security has returned to "not enabled". You can now partition and format the device.


Well, this depends completely upon OCZ, but the Vertex2 drives now come with the "OCZ Toolbox" software which can do the secure erase and reset the drive to an out-of-box state.

Go to this page -> http://www.ocztechnology.com/ssd_tools/

Even if your drive does not need a firmware update (Mine did), the software can emit the SECURE ERASE command. I had to use another computer to actually do it (you obviously can't initiate this from within Windows booted from the drive you're nuking) but it worked flawlessly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .