I've got a laptop which has a verified internet connection. I can ping www.google.co.uk and receive a response no problem. However IE, Chrome, Firefox, MSN messenger cannot connect to the internet.

I've tried the WINSOCK fix to no avail.

Any ideas?


The internet connection is verified as working on another computer, with no problems browsing or telnet. I have tried connecting both the working and 'non-working' pcs together with a network cable with the working PC sharing its internet connection. Only the working PC can browse, with the same symptoms on the 'non-working' one. They can both ping each other, although I've yet to transfer files. The connection is a USB 3G modem.

  • Is it working on other connection types? WLAN or LAN – schöppi Oct 28 '10 at 21:47
  • LAN seems to work fine (I connected the computers directly) however I'm again relying on PING between the two, I didn't transfer any files. – m.edmondson Oct 28 '10 at 21:50
  • Okay, so internet connection is a USB 3G modem that you plugin to two computers. One works, and the other does not? – benc Oct 29 '10 at 8:41
  • @benc - Exactly. Both run from the same place and both report full 3.5G connection so I think that can be ruled out – m.edmondson Oct 29 '10 at 8:54
  • Can you try removing the USB 3G thing, just connecting them each to a router? And not using one computer as a router and connecting the other one to it. And not even necessary both at the same time connected to the router. But just each computer connected to a router. Just one, then, just the other. – barlop Nov 1 '10 at 20:59

ping is not a reliable test of network connectivity. (I'll spare you the gory details).

If you want something to work, you need to check for the actual connection of the application.

Try: telnet www.google.co.uk 80

$ telnet www.google.co.uk 80
Connected to www.l.google.com.
Escape character is '^]'.

If it does not say "Connected", you can't make a TCP connection to the web server.

  • 4
    "I'll spare you the gory details". Do you have a link to info on that? – barlop Oct 27 '10 at 0:59
  • Also, regarding the command you give. In my case I -can- connect though it doesn't say connected, it just gives a blank screen. One can type GET <ENTER> then one sees HTML of the page. It doesn't say "connected" though in win xp anyway. – barlop Oct 27 '10 at 1:11
  • Thanks just tried this and it does NOT connect. Any other ideas why? – m.edmondson Oct 27 '10 at 22:53
  • 3
    ping uses ICMP packets. In the modern world, they are often routed differently than "normal" TCP or UDP traffic, which is what your actual applications run on. So if TCP doesn't work, no web. PING is irrelevant. – benc Oct 28 '10 at 7:24
  • Thanks for helping me understand PING, I tried telnet on another computer with the same connection and it worked with being able to return google's source. Any ideas why it won't work on this laptop? – m.edmondson Oct 28 '10 at 8:12

I would have to go with a hosed LSP problem...common with improperly removed malware or a hosed security software install. I had a version of McAffee that went horribly wrong utterly destroy networking on a PC. I look to LSP problems because ping and dns work. If he pings x.com and gets a response back from x.x.x.x then dns is up. The problem is probably packet inspection inside a layered service provider. Try looking into what LSPfix shows you, I think spybot s and d has this functionality now as well...hijackthis might too.

  • Excellent, do you have any links for me to try? – m.edmondson Nov 3 '10 at 16:29
  • It looks like HJT(hijack this) can display if you have LSPs.. LSPfix should fix any or the or some LSP issues! Here is a link that describes seeing LSPs with HJT. Not all LSPs are malicious or broken. bleepingcomputer.com/forums/topic3272.html I haven't used lspfix before. Should be interesting. – barlop Nov 3 '10 at 16:49
  • Can the machine get online using a Ethernet/Wifi connection other than the 3G modem? If it can't it is probably a LSP problem. If it can its an issue with the 3G modem's config – Honk Nov 3 '10 at 23:22
  • cexx.org/lspfix.htm is where to get lspfix...careful in removing LSPs as they are not all malicious and you CAN cause more harm than good...you may want to post output here for review – RobotHumans Nov 4 '10 at 13:36
  • note: ping IS an accurate test of end to end application layer connectivity. ICMP is routed similarly to tcp and udp. It does NOT however identify different ACLs on firewalls or content filtering. This can lead to false negatives(I can't ping but I can browse), but not false positive(I can ping, but I can't browse). It isolates it to a host problem not a net problem. Sorry for the flameish response to the ICMP isn't a tool to use thing, but I disagree strongly – RobotHumans Nov 4 '10 at 13:39

The most likely explanation is that your proxy settings are wrong.

  • Maybe your browsers are all set to use a web proxy that you can't access from where you've plugged in your laptop. They're probably all using the Windows system setting (a.k.a. Internet Explorer setting).

  • Maybe the network you're connected to now blocks direct web browsing and requires you to go through a proxy. If the system proxy setting hasn't been changed to point to the required proxy (it's an optional feature of DHCP, it may or may not be available on your particular network), you'll need to ask the network administrator what setting to use. (Or guess — if there's a machine called proxy on your network, you can try it with port 3128 or 8080.)

  • As far as I can tell there are no proxies configured and its a direct link to the internet – m.edmondson Oct 27 '10 at 22:55
  • @m.edmondson: If you have no proxy configured, you probably need one (second bullet point). – Gilles 'SO- stop being evil' Oct 27 '10 at 23:08
  • I don't think thats the issue. The internet connection is a 3G modem, which I can connect to other computers and it works fine. No proxies configured on the working computer - all set to detect automatically. – m.edmondson Oct 28 '10 at 8:14

There are 3 similar commands you can try, and it looks like you tried one already.

netsh winsock reset

netsh int reset

netsh int ip reset

try the browsers after that, though would probably need a restart after that.

may not work, but worth a try.

  • Thanks for your help. Just tried them all and rebooted to no avail. Any other ideas? – m.edmondson Oct 27 '10 at 22:54
  • Does another computer on the router work?(if it is a router) if so then the router is more likely ok.. if everybody is really stumped, then try a win xp repair installation michaelstevenstech.com/XPrepairinstall.htm – barlop Oct 28 '10 at 18:55
  • Yea theres no router involved, its a USB 3G modem connected directly to the computer. Verified as working on another computer and even when connecting both together via network cable, only the 'working' computer works (sharing its internet connection with the 'broken' one) – m.edmondson Oct 28 '10 at 21:36
  • no idea if this will help, but worth a try. support.microsoft.com/kb/936211/en-us "How to troubleshoot network connectivity problems in Internet Explorer " "Microsoft Automated Troubleshooting Services tools" – barlop Oct 30 '10 at 19:27
  • actually, probably better not to try that. I just tried it and now internet explorer is having trouble automatically downloading files, it says addons are disabled and i'm not sure right now how to get it to download a program I want to! So may be better to forget that it may be not worth the trouble, with a very small chance of fixing it. this is the first time i've used it. so i can't say i've experienced its usefulness. – barlop Oct 30 '10 at 22:05

Did you try connecting directly to the IP address of the machine?

e.g. for google.co.uk. Could be a DNS issue that is not showing up in PING.

  • Do you mean telnet or via the browser? I did try directly typing the IP in the browser to no avail. I attempted telnet to www.google.co.uk but not the IP so I'll give that a try. – m.edmondson Oct 28 '10 at 21:49
  • It works in both telnet and your browser, but if it won't connect it is not a DNS issue. – Resorath Nov 2 '10 at 22:49
  • Just to make sure, you did check your Local Area Connection properties to make sure Internet Protocol (TCP/IP) was installed and enabled right? and that the "Internet Protocol" Properties are using "Obtain an IP Address automatically" right? I guess that is the obvious troubleshooting step I would take first but I haven't seen it posted here yet. – Resorath Nov 2 '10 at 22:51
  • Yea thanks for trying though, TCP/IP is enabled and set to automatically get addresses – m.edmondson Nov 3 '10 at 16:30

See this Microsoft article:
How to determine and to recover from Winsock2 corruption in Windows Server 2003, in Windows XP, and in Windows Vista

It describes how to determine whether the Winsock2 key is corrupted, which uses the Netdiag tool found in the Windows XP CD, or using another method with the Msinfo32 program.

It also contains a Fix It button, as well as instructions on how to manually recover from Winsock2 corruption.

If you have tried everything possible to reset TCP/IP and it doesn't work on this one machine, and you have the latest drivers for the network card, then there might be a software problem.

I would suggest to first verify the system files as described here:
How to Repair Windows 7 System Files with System File Checker
How to use the Scannow SFC tool in Windows XP

If the problem is still there, then boot into Safe mode and try again.

If the problem disappears, then some installed product is blocking Internet access. Probably a firewall or some anti-virus suite.

If the problem is still there in Safe mode, then Windows itself is broken and needs repairing.

  • I've already tried the manual steps here, perhaps the automatic fix it may be worth a try – m.edmondson Nov 1 '10 at 11:36
  • I added some more stuff. – harrymc Nov 1 '10 at 11:55
  • Tried safe mode however it won't run detect the USB dongle, I booted safe mode with networking, do I need to enable USB support or something? – m.edmondson Nov 3 '10 at 16:31
  • I didn't know wireless came from USB. Unfortunately, only network (LAN) connections are supported in Safe Mode with Networking. So one needs to do it by steps. First step is to disable all security products such as firewall and antivirus, reboot and test "Mozilla Firefox (Safe Mode)" for no add-ons. – harrymc Nov 3 '10 at 17:54

windows can be finicky sometimes. Have you gone to your internet explorer settings and made sure that all of the Security and Privacy settings are at the default levels? Also make sure that the connection settings are setup to go through some sort of proxy (unless you need it to be configured that way)...

A lot of times, this will solve a lot of problems.

Good Luck

  • Tools->internet options->Advanced->reset is a handy way to fix these kinds of things. – Brian Nov 4 '10 at 21:20

check your mobile broadband adapter settings maybe its disabled. or if one of your adapters is disabled just enabled it even though you do not use it. its a common problem on Vista machines.


I had this problem when my PC crashed whilst fiddler was running. Opening fiddler and then closing it again fixed it.

(This won't be the answer to everyone's problems, but if you use fiddler there's a chance that this is the cause.)

  • You don't need to post the same answer 3 times. Please don't. – nhinkle May 2 '12 at 20:09
  • Sorry - did I post three times on this same question? Oops! I meant to post it as the answer to a few different questions: they were all ones I had looked at in my search for an answer. I figured it made sense to put my solution on each of them when I worked out the cause of my problems, to help later travellers on the same journey. – teedyay May 14 '12 at 20:50
  • No, you posted it on separate questions, but it's redundant. In cases like that it's more helpful to flag them as duplicates if the exact, word-for-word same answer actually applies to each of them. – nhinkle May 14 '12 at 22:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.