As you probably know Google Chrome has its own internal DNS cache. Is there a way to clear it without having to wait for the time out or close the browser?

  • 1
    The only reason for me to flush Chrome's DNS cache is because if I don't, I can't access Google. Luckily, Google's not the only search engine out there (or else I wouldn't have found this question) and I only have to deal with Chrome at work.
    – Nolonar
    Apr 11, 2013 at 9:16
  • For me, this is probably caused by having an incorrect DNS-server in resolv.conf. (I am trying to access an internal server on a VPN). The people at T-com have misconfigured their DNS to respond with their advertisement site instead of NXDOMAIN, and the people who wrote Chrome didn't care to respect the resolv.conf order, but instead happily use whatever DNS server appears to work.
    – Ketil
    Feb 21, 2014 at 2:32
  • related: apple.stackexchange.com/questions/121425/… Apr 30, 2014 at 12:51

17 Answers 17


Navigate to chrome://net-internals/#dns and press the "Clear host cache" button.

  • 48
    Strangely, this only works in one direction. I have a mapping in the hosts file that maps a domain name to the local machine (i.e. to, when I remove the mapping and flush the DNS cache in Chrome, it correctly loads the site from the internet, but when I add the mapping again to the hosts file, it still loads the site from the internet. It shows the cached DNS list empty in Chrome after clearing the DNS cache (also cleared the OS cache using ipconfig /flushdns), still, it loads the site from the internet! Seems like a bug.
    – Mee
    Oct 28, 2010 at 2:14
  • 10
    Even more annoying, Chrome shows the IP address correctly ( for that domain in the DNS cache list (after flushing and trying to load the site again), still it loads the site from the internet.
    – Mee
    Oct 28, 2010 at 2:15
  • 6
    awesome, is there a list of all the chrome://* options anyway does anyone know?
    – Ian
    May 13, 2011 at 9:18
  • 36
    @Ian chrome://about
    – ephemient
    Sep 24, 2011 at 18:47
  • 12
    Wasn't enough for me. Had to "ipconfig /flushdns" in command prompt (found in answer below)
    – Adam Tal
    May 27, 2014 at 21:47

Sometimes you need to flush the socket pools after flushing the DNS:

  • 5
    Note that Chrome now monitors the hosts file and autoclears the dnscache whenever there are any changes to the hosts file. —You can easily test if that works on your system by adding a blank line after your hosts file, and the list at chrome://net-internals/#dns will be autoupdated.— Windows' dnscache service will also (at least on win 8.1) monitor the hosts file for changes, so after you have updated your hosts file, simply clicking on the button "Flush socket pools" will work. Nothing else is needed.
    – Pacerier
    May 21, 2015 at 6:02
  • Yeah, I seem to have noticed the same behavior since 1 year or so. However, maybe it doesn't work all the time, for I still get the upvotes on this answer. May 21, 2015 at 6:45
  • Just tested on Server 2003 too. Whenever there are any changes to the hosts file, dnscache service automatically reloads the cache without any need for ipconfig /flushdns nonsense. ipconfig /flushdns seems to be a red herring in this entire issue.
    – Pacerier
    Jul 6, 2015 at 12:57
  • Worked for me, even after flushing dns in cmd and doing the accepted answer
    – Rob Scott
    Dec 3, 2015 at 14:43
  • 1
    No longer works.
    – Hippyjim
    Jan 17, 2018 at 21:33

"Navigate to chrome://net-internals/#dns" doesn't work in the Google Chrome browser, at least on my system. Looks like this solution maybe works for the Google Chrome OS, but not the Google Chrome browser more generally speaking. For me the link redirects here:
The Chromium Projects

It appears "Empty the Cache" is the better solution. Also note my browser says "Preferences" rather than "Options"

Via http://www.google.com/support/forum/p/Chrome/thread?tid=026b6a1d9151a6e3&hl=en

"Go to tools -> options -> Under the hood -> Clear Browsing data and check 'empty the cache' and click on clear browsing data. Yes yes, I know, it is not the DNS cache I would expect it to clear, but hey it seems to. And now it works for me."

  • 7
    Confirmed this worked for me, Clear Browsing Data -> Empty the cache. No other method worked. Thanks PJ.
    – Air
    Dec 29, 2012 at 23:04
  • This worked for me on both chrome and chromium when /etc/resolver/foo.com was being ignored.
    – chovy
    Sep 17, 2013 at 3:31
  • Looks like Google is gradually making name changes to some internal URLs over different versions. As of version 27.0.1421.0 (184274)... Jan 16, 2014 at 10:25
  • At least clearing Cached images and files did not work for me (Chromium 33 on Ubuntu) after turning on OpenVPN and thus switching my active DNS server. (Clear host cache as in the popular answer did not work either.) So far I have not found anything that works except restarting the browser, or entering the IP address in the URL. Apr 18, 2014 at 13:46
  • 6
    Clearing Cached images and files worked for me! No clue why, but it did. Windows 8.1, Chrome 41.0.2272.89 m
    – Bing
    Mar 29, 2015 at 18:53

Clicking "clear host cache" in chrome://net-internals/#dns should do it for Google Chrome, but there are other DNS caches to consider on your machine.


ipconfig /flushdns

OS X pre-10.7 (before Lion):

sudo dscacheutil -flushcache

OS X 10.7–10.9 (Lion, Mountain Lion, Mavericks):

sudo killall -HUP mDNSResponder

OS X 10.10+ (Yosemite):

sudo discoveryutil mdnsflushcache

OS X 10.11, 10.12+ (El Capitan, Sierra):

sudo killall -HUP mDNSResponder

Your router may be caching the DNS as well (restart it or read the manual). The ultimate test is to use dig, but this uses your network's DNS host, not the authoritative server by default:

dig superuser.com

To query right from the source, try something like:

dig superuser.com @ns1.serverfault.com
  • 1
    "sudo discoveryutil mdnsflushcache" didn't work on El Capitan (10.11) for me, but "sudo killall -HUP mDNSResponder" did, it said that discoveryutil did not exist, maybe it's Sierra and up?
    – Ezra
    Nov 2, 2016 at 11:41

In OS X 10.9.1 w/ Chrome 32 I needed to both clear the host cache and flush the socket pools to get Chrome to refresh the DNS cache:

  1. Navigate to chrome://net-internals/#dns and click "Clear Host Cache"
  2. Navigate to chrome://net-internals/#sockets abd click "Flush Socket Pools"
  • I needed it in Windows 8.1 as well, so it's not just OS X.
    – benrick
    Jul 14, 2014 at 2:34
  • Chrome for Linux also need it chrome://net-internals/#sockets
    – pengemizt
    Dec 17, 2014 at 11:51
  • 2
    Chrome for Linux just needs a socket flush. No DNS flush. superuser.com/a/611712/30982 Feb 5, 2016 at 17:04

This worked for me: Empty and clear the disk cache

In Chrome, click on the wrench icon, and then Options. Go to Under the Hood tab. Click on the Clear browsing data button under the Privacy section. Select just the "Empty the cache" check box, and then click on the Clear browsing data button.

This worked immediately - I didn't even have to close the browser.

  • 1
    This seems to work to force Chrome to recognize changes to the hosts file.
    – minamhere
    Jun 26, 2012 at 2:39
  • This worked for me on Mac Chrome, after having tried the chrome://net-internals/#dns flush trick mentioned here, without success. Mar 10, 2014 at 20:16

As far as I can find, in recent versions of Chrome (I'm on 26.0.1410.43), there's no (reliable) way to do it, at least not on a Mac. None of the suggestions on this page have worked for me.

My situation is that I've added a hosts file entry, but Chrome is still going to the IP address returned by DNS. Firefox works correctly.

In fact, the chrome://net-internals/#dns page is simply lying about the IP address for me. It shows the IP from the hosts entry, but that is clearly not where it's actually getting the site from.

  • 2
    Same problem here. I have tried clearing cache, clearing the internal DNS cache, ipconfig flush dns, and it is still loading a local website from the live domain. If I open it in "Incognito" it works, or in Firefox it works, but normal Chrome refuses to reset its DNS Apr 23, 2013 at 14:43

I know this is an old question but I got annoyed by same the complaints as others: even after clearing the cache it can still take a minute or two for the new DNS changes to kick in.

There are a few ways around it. After clearing the DNS cache through chrome://net-internals/#dns (or using an extension that achieves the same result):

  1. Open an incognito window and the new DNS mappings for the domain will be effective immediately.

  2. Clear the browser cache. This is cumbersome if you use your browser for regular browsing. You can run a separate instance of the browser as another user and clearing the cache in that account will not interfere with your regular browsing cache. I haven't tried this but it should work.

  3. Hit CTRL+F5. I had to keep CTRL+F5 pressed for about one second which consecutively reloads the page a couple of times. This is odd behavior but it works and is also just as effective. This is my preferred approach.

Ideally there ought be a plugin that can purge the DNS and cache (specifically just the document cache and not the cookie cache) but I didn't find anything of the sort yet.

UPDATE: On OSX the Gas Mask application is excelling for switching between hosts files and along with the #2 workaround, it's quite effective.

  • 2
    Refreshing will not help one bit. The active TCP sockets will still be active. You either wait it out (1-2 minutes) or manually flush them.
    – Pacerier
    May 21, 2015 at 6:23
  • Clearing the browser cache is the only thing that works for me, even after waiting for a 15 minutes or so... Thanks!
    – Hay
    Sep 14, 2020 at 9:30


It is to resolve the problem that Chrome can't use the correct hosts after modifying the hosts file because of Chrome using socket pools.

Chrome maintains long connections in the connection pool to speed up. When Chrome finds that a request can reuse a connection in the connection pool, it won't go through the DNS again, thus, we always perceive that Chrome won't respond to a hosts change immediately.

Chrome has provided an interface for flushing the connection pool in the chrome://net-internals/#sockets tab, but I think it's annoying that I have to go to the tab first, and click so a small button with a trackpad.

I found that when clicking the button of flush socket pool, Chrome executes two key JavaScript methods.


So I encapsulate these two methods in an AppleScript script which can be converted to an OS X application or Alfred workflow which both can be invoked easily.

  • Hi Boreas320, can you provide a summary of what your link provides in your answer in case it becomes out of date? Answers that are only/mostly a link are discouraged as they can go stale.
    – bertieb
    Aug 3, 2015 at 12:41
  • Up! Wonderful idea! Thanks! However it didn't work for me until I replaced the javascript with document.getElementById('sockets-view-flush-button').click();
    – i_a
    Jun 22, 2017 at 21:11

5 years later...

Chrome now has an option to disable cache.

  1. Press F12 (or Ctrl+Shift+I) to call up the DevTools.
  2. Go to Network Tab
  3. Check the "Disable Cache" box.
  4. Reload the page
  5. Right-click the reload button so that the menu opens. Select “Empty Cache and Hard Reload”.
  6. Enable cache in DevTools.

This also solves the redirect cache (chrome caches permanent redirects)

Source: mwender.com


I tried to flush the DNS cache in so many ways, but nothing worked for me. At last, I planned to change my DNS entry. This trick will work for all people who access Internet through high speed LAN connection.

On a LAN connection, a user is generally provided two DNS addresses. One is primary and another is secondary or alternative DNS address. What I did was that I just changed the secondary address to the primary address and vice-versa. It worked for me instantly.

I kept the alternative DNS address as primary address for two days. The problem solved itself and later, I reinstated the old DNS entry.


Full process:

Created site in IIS (windows 8), set host header.

Tried hitting the the host with no host file, ensuring to use http:// so it does not just do a google search. Correctly failed in chrome "Version 32.0.1700.76 m"

Add host to host file as, now can hit it in chrome.

Remove from host file and run ipconfig /flushdns, chrome still shows site!

Do nothing other than CTRL+F5 and now site correct fails in Chrome.

With the number of different answers here I wonder if we all have slightly different use cases.


For me private browsing did the trick (New incognito window/ private window).

  • Hi Bart, welcome to Superuser! Unfortunately, this question is about the computer-version of Chrome, not the mobile version. I'd suggest editing your answer to reflect the desktop version. Thanks Feb 21, 2014 at 2:35

For iPhone users, these techniques work just as effectively. I had to do some testing of a website, and I wanted to override the normal DNS server and use my own DNS server with DNS entries that are not yet public.

I override the DNS entry in my wifi setting on my iPhone 6 Plus to my custom DNS server. That was good enough for Safari and Perfect Browser. But Chrome seemed to ignore that and had its own set of DNS entries. I could NOT figure out where they came from.

I did what they described above

  1. Navigate to chrome://net-internals/#dns and click "Clear Host Cache"
  2. Navigate to chrome://net-internals/#sockets abd click "Flush Socket Pools"

AND I had to also Use an InCognito Tab as mentioned above.

Only THEN did Chrome use my custom DNS entry.

  • Incognito tab worked for me.
    – vaughan
    Aug 28, 2021 at 2:03

Try DNS Flusher for Chrome. Note that to use it, it requires a command line flag, --enable-benchmarking when you start the Chrome browser.

  • extension no longer exists
    – jmgarnier
    Apr 1, 2019 at 8:47
  • @jmgarnier it actually does.
    – avia
    Nov 23, 2021 at 6:33

Navigate to chrome://net-internals/#dns and press the "Clear host cache" button. as answered already Also you may need dscacheutil -flushcache command in OS X, to flush system-wide DNS cache. ipconfig /flushdns in windows command prompt


On Mac OS X, none of the above mentioned approaches worked for me. The following approach did:

Click Chrome menu > preferences > click the link show advanced settings in the bottom of the page > click clear browsing data button in privacy section > only select cached images and files and download history (perhaps the later isn't required, but doesn't hurt either) > click clear browsing data button.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .