I just upgraded my Linux guest running on Win7-64 VirtualBox 3.2.10 from Ubuntu 10.04 to 10.10. I followed the usual steps to reapply guest additions, including installing build-essential and linux-headers-... before running the guest additions installer. No errors or warnings occurred in the installer, which output messages indicating that it was using all the X11 stuff, and I restarted the guest. I also checked that 3D acceleration is on.

Despite everything seeming to go quite smoothly, I am no longer able to turn on Extra effects in System|Preferences|Appearance|Visual Effects. It was working a treat with 10.04. When I click the button, it spends about 15 seconds searching for available drivers, flickers everything, grays out the dialog box for another five seconds or so, then finally pops up a dialog box that says, "Desktop effects could not be enabled". The same thing happens when I click "Normal" or "Custom" (except that the driver search only happens the first time I click any of these options).

UPDATE: I get the same output, and the same outcome, if I run the installation script as root.

Why can't I turn on Extra Visual Effects after upgrading to Ubuntu 10.10?

Random machine specs:

marcelo@ubuntu:~$ uname -a
Linux ubuntu 2.6.35-22-server #35-Ubuntu SMP Sat Oct 16 22:02:33 UTC 2010 x86_64 GNU/Linux
marcelo@ubuntu:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick
marcelo@ubuntu:~$ ls /media/

Here's a re-run of the guest additions install:

Verifying archive integrity... All good.
Uncompressing VirtualBox 3.2.10 Guest Additions for Linux........
VirtualBox Guest Additions installer
Removing installed version 3.2.10 of VirtualBox Guest Additions...
Uninstalling old VirtualBox DKMS kernel modules ...done.
Building the VirtualBox Guest Additions kernel modules
Building the main Guest Additions module ...done.
Building the shared folder support module ...done.
Doing non-kernel setup of the Guest Additions ...done.
You should restart your guest to make sure the new modules are actually used

Installing the Window System drivers
Installing X.Org Server 1.9 modules ...done.
Setting up the Window System to use the Guest Additions ...done.
You may need to restart the hal service and the Window System (or just restart
the guest system) to enable the Guest Additions.

Installing graphics libraries and desktop services components ...done.
Press Return to close this window...
  • Tried restarting the VM ? – Sathyajith Bhat Oct 27 '10 at 2:55
  • @Sathya: Yes, I did; several times, in fact. – Marcelo Cantos Oct 27 '10 at 2:57
  • That's .. odd. Try removing guest-additions from Ubuntu Software centre, just to be sure. – Sathyajith Bhat Oct 27 '10 at 4:31
  • ...or re-installing the guest-additions. – Boldewyn Oct 27 '10 at 10:00
  • The guest-additions from Software Center haven't been loaded, AFAICT, and I've tried reinstalling them several times now. I haven't tried uninstalling the version installed by VBox because a) I don't know how, and b) it seems that the installer does that anyway. There isn't much on this VM that I need to keep, so unless someone is keen to get to the bottom of it, I will probably just do a reinstall from scratch in the (Australian) morning. – Marcelo Cantos Oct 27 '10 at 10:08

Try installing dkms as well:

sudo apt-get install dkms

build-essentialis needed as well most likely, but you said you already had that installed.

  • Dkms did the trick. I had to reinstall the guest additions after installing dkms and then reboot the guest, but I now have lovely wobbly windows. Woo-hoo! – Marcelo Cantos Nov 10 '10 at 0:06

I had this problem.

Make sure you have all 128MB assigned to graphics, and make sure VT-X, ACPI etc are all switched on, I had to reinstall the additions a couple of times before it worked.

  • Thanks for the suggestion. I did have it set too low, but adjusting it made no difference. – Marcelo Cantos Nov 10 '10 at 0:05

@gencha omg, I was just running into the same exact problem as the OP. At first I thought I was doing something wrong since this is my first time trying out VirtualBox. My setup is almost the same as his, host is Win7 64-bit, guest is Ubuntu10.10 64-bit. I've followed the instructions found around the web to the letter and couldn't get it to work.

I tried gencha's suggestion and went ahead downloaded dkms. Reinstalled the Guest Addition, and a restart later boom! it works! And here I was spending hours cursing this stupid thing wondering why it doesn't just work.

I would upvote you gencha but it's a bit difficult since I don't have 15 rep on this site yet :(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.